php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43316 About the bug #42590
Submitted: 2007-11-17 01:28 UTC Modified: 2007-11-18 13:51 UTC
From: dagdamor at simps dot ru Assigned: iliaa (profile)
Status: Not a bug Package: Strings related
PHP Version: 5.2.5 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dagdamor at simps dot ru
New email:
PHP Version: OS:

 

 [2007-11-17 01:28 UTC] dagdamor at simps dot ru
Description:
------------
http://bugs.php.net/bug.php?id=42590

I don't understand the issue... since when \v and \f are escape sequences? According to the manual (http://www.php.net/manual/en/language.types.string.php), those are just regular character sequences, backslash followed with letter.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-11-17 22:24 UTC] jani@php.net
Ilia, you propably should explain this..? :D
 [2007-11-18 13:51 UTC] iliaa@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

\v and \f are escape sequences since, well, ever. PHP due to a bug had 
simply failed to implement them before. Further more, if you are using 
heredoc or double quotes you should ALWAYS escape the \ if you want it 
to be rendered properly. 
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Dec 15 00:01:22 2019 UTC