php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43285 Mac style line endings in source files
Submitted: 2007-11-14 04:29 UTC Modified: 2007-11-17 22:22 UTC
From: ezyang@php.net Assigned:
Status: Not a bug Package: DBM/DBA related
PHP Version: 5.2CVS-2007-11-14 (CVS) OS: Windows Vista
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ezyang@php.net
New email:
PHP Version: OS:

 

 [2007-11-14 04:29 UTC] ezyang@php.net
Description:
------------
ext/dba/dba_db1.c has Mac style newlines, so the compiler complains. Should be an easy fix.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-11-14 11:46 UTC] jani@php.net
Exactly what compiler complains about it? Using any sane compiler doesn't cause any complaints. Are they errors / warnings?
 [2007-11-14 11:47 UTC] jani@php.net
Copied from the other report:

In the ext/pdo_odbc directory, odbc_driver.c, odbc_stmt.c and
php_pdo_odbc_int.h have Mac style newlines.

 [2007-11-14 18:41 UTC] ezyang@php.net
Microsoft Visual C++ 2005 Express fails when it encounters code with Mac-style newlines. It specifically says "Does not support Mac style newlines, please convert to Windows / Unix style"

Maybe a faulty CVS checkout?
 [2007-11-14 20:02 UTC] ezyang@php.net
Taking a look at the binary markup of the files, it looks like the newlines are being represent as 0d 0d 0a (\r\r\n) which is not really any type of newline at all. :-)
 [2007-11-16 12:36 UTC] jani@php.net
I can't find any "mac style" EOLs in any of those files..are you sure you have clean sources?
 [2007-11-17 03:22 UTC] ezyang@php.net
The behavior only manifests when CVS auto-converts the files to Windows style newlines (performing the checkout with Unix style newlines works fine), but the behavior is consistent and reproduceable.
 [2007-11-17 22:22 UTC] jani@php.net
There's nothing wrong with the actual sources, just your CVS configuration. Please ask further support questions elsewhere.
Or just switch using some real OS.. :D
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Mar 22 12:01:27 2019 UTC