php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43273 getElementsByTagNameNS doen't find nodes
Submitted: 2007-11-13 00:34 UTC Modified: 2007-11-13 10:37 UTC
From: jose dot rob dot jr at gmail dot com Assigned:
Status: Not a bug Package: DOM XML related
PHP Version: 5.2.5 OS: Gentoo Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jose dot rob dot jr at gmail dot com
New email:
PHP Version: OS:

 

 [2007-11-13 00:34 UTC] jose dot rob dot jr at gmail dot com
Description:
------------
When I use a prefix, getElementsByTagNameNS doesn't find it until I save and load again.

Reproduce code:
---------------
<?php
$xml=new DOMDocument();
$root=$xml->createElementNS('example','ex:root');
$xml->appendChild($root);
for($i=1;$i<=3;$i++){
	$child=$xml->createElement("ex:child$i");
	$root->appendChild($child);
}
for($i=0;$i<=1;$i++){
	if($i){
		echo "* reloading<br/>";
		$XML=$xml->saveXML();
		$xml->loadXML($XML);
	}
	$ns=$xml->getElementsByTagNameNS('example','*');
	foreach($ns as $ex){
		echo $ex->nodeName."<br/>";
	}
}
?>

Expected result:
----------------
ex:root<br/>
ex:child1<br/>
ex:child2<br/>
ex:child3<br/>
* reloading<br/>
ex:root<br/>
ex:child1<br/>
ex:child2<br/>
ex:child3<br/>


Actual result:
--------------
ex:root<br/>
* reloading<br/>
ex:root<br/>
ex:child1<br/>
ex:child2<br/>
ex:child3<br/>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-11-13 10:37 UTC] rrichards@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

dupe of bug #43273
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jul 31 00:01:23 2021 UTC