php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43249 PHP 5.2.3 & MSSQL
Submitted: 2007-11-11 19:43 UTC Modified: 2007-11-12 11:26 UTC
From: swapneel at networkredux dot com Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 5.2.5 OS: CentOS release 4.5 (Final)
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: swapneel at networkredux dot com
New email:
PHP Version: OS:

 

 [2007-11-11 19:43 UTC] swapneel at networkredux dot com
Description:
------------
Hello,

PHP Build : 5.2.3 running as CGI. 

FreeTDS version 0.64

FreeTDS configure statement has,

./configure --with-tdsver=7.0 --prefix=/usr/local/freetds --enable-msdblib

PHP configure statement has,
--with-mssql=/usr/local/freetds

Configure(PHP5.2.3) has,

checking for MSSQL support via FreeTDS... yes


Complile and install is fine. mssql section shows up in phpinfo(). 

However, script still fails with call to undefined function,

Fatal error: Call to undefined function: mssql_connect() in /home/username/public_html/script.php

I've tried PHP 5.2.5 with no luck. It would be much appreciated if anyone could point out what is going wrong. Thanks. 



Actual result:
--------------
Fatal error: Call to undefined function: mssql_connect() in /home/username/public_html/script.php

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-11-12 11:26 UTC] jani@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jun 22 07:01:29 2024 UTC