php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43215 php5ts.dll is not installed using Windows Installer
Submitted: 2007-11-08 00:32 UTC Modified: 2008-08-22 18:16 UTC
From: zippy333 at hotmail dot com Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.2.4 OS: Windows Server 2008 RC0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: zippy333 at hotmail dot com
New email:
PHP Version: OS:

 

 [2007-11-08 00:32 UTC] zippy333 at hotmail dot com
Description:
------------
When installing PHP using the Windows Installer (msi) file, php5ts.dll is not installed.
My setup:
- Windows Server 2008 RC0 - x64
- IIS
- CGI enabled for installation with Fast CGI

Reproduce code:
---------------
- Download installer and run it.
- Select IIS/CGI configuration
- Notice that C:\Program Files(x86)\PHP\php5ts.dll doesn't exist.

Expected result:
----------------
php5ts.dll should be installed because it's the most needed file of PHP.

Actual result:
--------------
php5ts.dll is not installed.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-11-11 18:45 UTC] jani@php.net
Assigned to the installer maintainer.
 [2007-11-12 12:57 UTC] jmertic@php.net
Could you run it in verbose logging mode and send the log file to jmertic@php.net? To run in verbose logging mode issue the below command from the command prompt ( from the same directory where the install exists ):

msiexec /i php-5.2.4-win32-installer.msi /l*v error.log
 [2007-11-16 23:45 UTC] zippy333 at hotmail dot com
I've closed this bug because I was not able to reproduce it anymore. The dll is now always installed.

One thing that could have caused the problem was the selection of a certain extension. I can't remember which ones I selected exactly.
When the bug occured repairing/changing the installation didn't cause the dll to be installed.

Maybe I downloaded a faulty package.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jul 07 04:03:36 2022 UTC