php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43184 PHP outputs a weird error in the CGI log.
Submitted: 2007-11-03 19:49 UTC Modified: 2007-11-20 01:00 UTC
Votes:8
Avg. Score:4.8 ± 0.7
Reproduced:8 of 8 (100.0%)
Same Version:5 (62.5%)
Same OS:6 (75.0%)
From: trustpunk at gmail dot com Assigned:
Status: No Feedback Package: CGI/CLI related
PHP Version: 5.2.5RC2 OS: Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
41 - 33 = ?
Subscribe to this entry?

 
 [2007-11-03 19:49 UTC] trustpunk at gmail dot com
Description:
------------
I don't have any errors in my PHP code but I see that in my CGI log, I have this weird error. This shows up with every PHP release I download.


Reproduce code:
---------------
Just run a few PHP pages on your server and you will get the nasty error
posted below in your CGI log file.

Note: This happens every time a new instance of "php-cgi.exe" is started.

<!---CGI LOG--->
03/Nov/2007:15:30:45 -0500	SUID: 0	PUID: 0	RUID: 0	URI: 	Reading 0 bytes failed = The process cannot access the file because it is being used by another process.
03/Nov/2007:15:30:45 -0500	SUID: 0	PUID: 0	RUID: 0	URI: 	timeout-header2!

Expected result:
----------------
I don't want to see that error in my CGI log file again. What is going on?

Actual result:
--------------
<!---CGI LOG--->
03/Nov/2007:15:30:45 -0500	SUID: 0	PUID: 0	RUID: 0	URI: 	Reading 0 bytes failed = The process cannot access the file because it is being used by another process.
03/Nov/2007:15:30:45 -0500	SUID: 0	PUID: 0	RUID: 0	URI: 	timeout-header2!
<!---End of CGI LOG--->

It never stops! It just keeps logging that garbage every few requests.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-11-05 15:30 UTC] crescentfreshpot at yahoo dot com
http://support.microsoft.com/kb/890015
 [2007-11-05 18:36 UTC] trustpunk at gmail dot com
It's PHP because my Mac outputs a similar error. The only difference between the Windows and Mac is that the Mac outputs a Broken Pipe instead of the original error Windows outputs.

<!---CGI LOG--->
05/Nov/2007:13:31:25 -0500	SUID: 0	PUID: 0	RUID: 0	URI: 	Reading 0 bytes failed = Broken pipe
05/Nov/2007:13:31:25 -0500	SUID: 0	PUID: 0	RUID: 0	URI: 	timeout-header2!
<!---END OF CGI LOG--->
 [2007-11-12 09:53 UTC] tony2001@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc. If the script requires a 
database to demonstrate the issue, please make sure it creates 
all necessary tables, stored procedures etc.

Please avoid embedding huge scripts into the report.


 [2007-11-13 22:33 UTC] trustpunk at hotmail dot com
This has nothing to do with the type of code being used, it has something to do with the FastCGI implementation itself. The author of Abyss Web Server explains about this: 

Author Reply #1
"The reported error is caused by PHP which does not usually "behave" as expected when started in FastCGI mode (there is a negotiation between the Web server and the FastCGI application that takes place at the startup of a FastCGI application, but PHP sometimes refuses to answer all the Web server queries about its capabilities hence the error)."

Author Reply #2
"It's related to the PHP FastCGI implementation which does not conform to the FastCGI spec sometimes. The good news is that this error could be ignored as it does not affect PHP or Abyss (Abyss reports it but ignores it)."


Hopefully this information will help you solve the problem. It has nothing to do with the web server software.

Kind regards, Josh
 [2007-11-20 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jun 15 17:01:31 2024 UTC