php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #43129 ldap_start_tls fails without ldap.conf
Submitted: 2007-10-29 17:44 UTC Modified: 2007-11-29 01:00 UTC
From: micah at onshore dot com Assigned:
Status: No Feedback Package: Documentation problem
PHP Version: 5.2.4 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: micah at onshore dot com
New email:
PHP Version: OS:

 

 [2007-10-29 17:44 UTC] micah at onshore dot com
Description:
------------
I get a TLS Connect error when I do not have the ldap.conf file in C:\OpenLDAP\sysconf.  In that file I need 'TLS_REQCERT never'.  This is not documented on the start_tls function.  Also, it would be nice if we can specify where the file goes.  Or, even better, if we can just set this as an LDAP option without the conf file.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-10-29 20:55 UTC] jani@php.net
Reclassified.
 [2007-11-21 14:04 UTC] vrana@php.net
Isn't the path to ldap.conf get some environment variable? How did you figure out to use C:\OpenLDAP\sysconf?
 [2007-11-29 01:00 UTC] doc-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Nov 13 15:01:28 2019 UTC