|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43039 Seg Fault (11) when using DB4 handler
Submitted: 2007-10-19 14:45 UTC Modified: 2007-10-30 01:00 UTC
Avg. Score:4.6 ± 0.8
Reproduced:5 of 5 (100.0%)
Same Version:5 (100.0%)
Same OS:5 (100.0%)
From: philippe dot gablain at gmail dot com Assigned: helly (profile)
Status: No Feedback Package: DBM/DBA related
PHP Version: 5.2.4 OS: Linux Ubuntu 7.10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: philippe dot gablain at gmail dot com
New email:
PHP Version: OS:


 [2007-10-19 14:45 UTC] philippe dot gablain at gmail dot com
Segmentation fault got anytime I call dba_open() since I upgraded from Ubuntu 7.04 French to 7.10 French (Apache 2.2.4,PHP5.2.3).

Reproduce code:
$dbfile=" some ";

$id = dba_open ($dbfile, "n", "db4"); // tested wl or n

if (!$id) {
    echo "dba_open failed\n";

dba_replace ("key", "some value", $id);
echo "<PRE>\n";
if ($the_key = dba_firstkey($id)) do {
    print("$the_key => ");
    print dba_fetch($the_key, $id);
} while ($the_key = dba_nextkey($id));
echo "</PRE>\n";

dba_close ($id);

Expected result:
key => some value

Actual result:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1216125264 (LWP 1289)]
0x085d7410 in ?? ()
(gdb) bt
#0  0x085d7410 in ?? ()
#1  0xb71f09ad in dba_open_db4 () from /usr/lib/apache2/modules/
#2  0xb71eefe5 in ?? () from /usr/lib/apache2/modules/
#3  0x08603d1c in ?? ()
#4  0xbfb590f8 in ?? ()
#5  0x00000001 in ?? ()
#6  0x00000000 in ?? ()


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2007-10-21 15:37 UTC]
Please try using this CVS snapshot:
For Windows (zip):

For Windows (installer):

Works fine in CVS, could be an issue with a buggy db4 library.
 [2007-10-21 15:44 UTC]
just tried it with db4.4 (default on Ubuntu 7.10) and it crashed, 
then I tried with db4.6 which works..
 [2007-10-22 20:22 UTC]
What version of db 4.4 is that exactly?
 [2007-10-30 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2008-01-07 10:52 UTC] gchiesa at smos dot org
same issue with Ubuntu 7.10 and dba4.

$ dpkg -la | grep db4 

ii  libdb4.2                                   4.2.52+dfsg-2ubuntu1                Berkeley v4.2 Database Libraries [runtime]
ii  libdb4.3                                   4.3.29-8ubuntu2                     Berkeley v4.3 Database Libraries [runtime]
ii  libdb4.4                                   4.4.20-8.1ubuntu3.1                 Berkeley v4.4 Database Libraries [runtime]
ii  libdb4.5                                   4.5.20-5ubuntu3                     Berkeley v4.5 Database Libraries [runtime]
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Aug 12 10:01:25 2020 UTC