php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42983 Regression: global variables get lost
Submitted: 2007-10-15 21:49 UTC Modified: 2007-10-16 21:03 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: marc dot bau at gmx dot net Assigned:
Status: Not a bug Package: Variables related
PHP Version: 5.2.4 OS: WinXP & openSUSE 10.3
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: marc dot bau at gmx dot net
New email:
PHP Version: OS:

 

 [2007-10-15 21:49 UTC] marc dot bau at gmx dot net
Description:
------------
Hi

i think i've struggled about a critical bug in 5.2.4 on Windows XP IIS with ISAPI and openSUSE 10.3 with Apache 2.2.4. The "global" variables looks simply lost. I've tried to install a
multilingual version of Drupal 5.2 and as i figured out the "global
$install_locale;" variable gets lost anywhere...

I have downgraded to PHP 5.2.1 re-testet (works) and upgraded back to
PHP 5.2.3 works, too.

Greetings
Marc

Reproduce code:
---------------
Install Drupal 5.2 with YAML for Drupal Complete package and you will see the global var gets lost and drupal is not installed in a selected language as it should.

I'm sorry i have no small and easy repro code...

Expected result:
----------------
not lost global variables

Actual result:
--------------
PHP 5.2.3 and 5.2.1 works well, 5.2.4 is broken

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-10-15 22:11 UTC] johannes@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2007-10-16 06:26 UTC] marc dot bau at gmx dot net
i have no idea what you need.

Install http://www.yaml-fuer-drupal.de/de/download (yaml-for-drupal-5.x-3.0.3.7.tar.gz). Unpack and start install ./install.php, select YAML as Install profile and German as your language. Try to stracktrace why $install_locale in \profiles\yaml\yaml.profile gives nothing back.

global $install_locale;
if ($install_locale == 'de') {

or inside the _autolocale_install_po_files() function file "sites\all\modules\autolocale\autolocale.install" the $install_locale is no more filled with "de", too.

I have no idea how to repro this, but this code works with <=5.2.3 and is broken with 5.2.4. If you don't like to repro try to look the PHP source and find out what's wrong here... shouldn't be impossible to find, while we know this is a regression introduced with 5.2.4
 [2007-10-16 06:30 UTC] marc dot bau at gmx dot net
Sorry, you need the install package drupal-5.2-yaml-for-drupal-5.x-3.0.3.7-2007092601.tar.gz
 [2007-10-16 10:54 UTC] crrodriguez at suse dot de
if evil^Wglobal variables gets lost, then there is definately a way to shortly reproduce the problem, have you contacted drupal developers about this problem ?
 [2007-10-16 20:38 UTC] marc dot bau at gmx dot net
Thank you for the snapshot links. i tried the Windows installer package and get:

"The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2878".

And then setup closes.
 [2007-10-16 20:51 UTC] marc dot bau at gmx dot net
I have reinstalled my 5.2.3 and replaced the directory with the ZIP version and tested latest 5.2.5-dev... and it WORKS! So i'd like to know - is there a list of bugs fixed until today so i can get an idea about the bug?

The new openSuSE 10.3 final contains PHP 5.2.4 and is therefore broken... i'd like to get this fixed, but i don't want to compile myself! Maybe SuSE will provide a hotfix for this... i don't know - but i think we should know which patch causes this bug and how heavy others might depend on this... or we have a half year to wait for the next openSUSE to get this fixed if they update their packages.
 [2007-10-16 21:03 UTC] johannes@php.net
It's hard to find the relevant patch without a proper and easy reproduce case - maybe the SuSE guys have more time for that research.

Nonetheless: The problem is fixed on our side.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Apr 21 08:01:27 2024 UTC