php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42851 echo("PKO");
Submitted: 2007-10-04 08:13 UTC Modified: 2007-10-04 12:38 UTC
From: lewis dot jones at virtualcollege dot ac dot uk Assigned:
Status: Not a bug Package: Streams related
PHP Version: 5.2.4 OS: Windows XP Pro
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: lewis dot jones at virtualcollege dot ac dot uk
New email:
PHP Version: OS:

 

 [2007-10-04 08:13 UTC] lewis dot jones at virtualcollege dot ac dot uk
Description:
------------
Windows XP
Running under IIS6 as ISAPI

Use echo("PKO****") results in page wanting to download as a zip file. PKO must be in upper case and the first three characters of the string.

Reproduce code:
---------------
echo("PKO");

Expected result:
----------------
PKO

Actual result:
--------------
Resulting page wants to open as a zip file

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-10-04 12:38 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

I suspect IIS looks @ the header and modifies the content-type of the 
page to application/zip
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Oct 18 19:01:28 2019 UTC