php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42787 max_execution_time not working
Submitted: 2007-09-28 11:05 UTC Modified: 2007-09-30 12:35 UTC
From: th at domainbox dot de Assigned:
Status: Not a bug Package: Performance problem
PHP Version: 4.4.7 OS: Debian Etch
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: th at domainbox dot de
New email:
PHP Version: OS:

 

 [2007-09-28 11:05 UTC] th at domainbox dot de
Description:
------------
If i start the attached code via .so module in Apache or with "php -f" it will run forever.


Reproduce code:
---------------
<?
ini_set('max_execution_time','10');
while (true){
 sleep(1);
}
?>

Expected result:
----------------
max_execution_time exceeded

Actual result:
--------------
Script runs longer than max_excution_time and does not get killed.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-09-30 12:35 UTC] nlopess@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

'max_execution_time' really means cpu execution time. sleep() doesnt consume cpu, so it isn't counted. Anyway, the script won't run forever, although it may run for a while..
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Mar 29 22:01:26 2020 UTC