php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42759 Can't compile with support with Oracle 10g
Submitted: 2007-09-25 14:11 UTC Modified: 2007-09-25 17:05 UTC
From: jarancibia at nacion-seguros dot com dot ar Assigned:
Status: Closed Package: OCI8 related
PHP Version: 5.2.4 OS: Debian Etch 4.0
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: jarancibia at nacion-seguros dot com dot ar
New email:
PHP Version: OS:

 

 [2007-09-25 14:11 UTC] jarancibia at nacion-seguros dot com dot ar
Description:
------------
I try to install php 5.2.4 and php 5.2.3 and not work make step:

make clean

export ORACLE_HOME=/opt/oracle/app/oracle/product/client10g
export PERL5LIB=\:/opt/oracle/app/oracle/product/client10g/perl/lib/5.8.3\:/opt/oracle/app/oracle/product/client10g/perl/lib/site_perl/5.8.3
export LD_LIBRARY_PATH=/opt/oracle/app/oracle/product/client10g/lib\:/opt/oracle/app/oracle/product/client10g/network/lib

./configure --prefix=/usr \
  --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin \
  --libexecdir=/usr/libexec --datadir=/usr/share \
  --sysconfdir=/etc --sharedstatedir=/usr/com \
  --localstatedir=/var --libdir=/usr/lib \
  --includedir=/usr/include --infodir=/usr/share/info \
  --mandir=/usr/share/man --with-apxs2=/usr/bin/apxs2 \
  --enable-debug --with-config-file-path=/etc \
  --enable-safe-mode \
  --with-exec-dir \
  --enable-sigchild \
  --disable-ipv6 \
  --with-openssl \
  --with-zlib \
  --with-bz2 \
  --enable-calendar \
  --with-curl \
  --with-gdbm \
  --with-gd \
  --enable-ftp \
  --with-jpeg-dir=/usr \
  --with-png-dir \
  --with-freetype-dir=/usr/lib \
  --with-ttf \
  --with-gettext \
  --enable-magic-quotes \
  --with-gmp \
  --with-mcrypt \
  --with-mysql-sock=/var/run/mysqld/mysqld.sock \
  --with-oci8 \
  --with-pspell \
  --enable-sockets \
  --with-regex=system \
  --enable-sysvsem \
  --enable-sysvshm \
  --enable-wddx \
  --enable-zip \
  --with-zlib-dir \
  --with-pic \
  --disable-rpath \
  --enable-inline-optimization \
  --enable-discard-path=yes \
  --enable-force-cgi-redirect=yes \
  --with-layout=GNU \
  --with-tsrm-pthreads \
  --enable-maintainer-zts


Reproduce code:
---------------
Output of make command:

 /root/php-5.2.3/meta_ccld -Iext/oci8/ -I/root/php-5.2.3/ext/oci8/ -DPHP_ATOM_INC -I/root/php-5.2.3/include -I/root/php-5.2.3/main -I/root/php-5.2.3 -I/usr/include/libxml2 -I/root/php-5.2.3/ext/date/lib -I/usr/include/freetype2 -I/opt/oracle/app/oracle/product/client10g/rdbms/public -I/opt/oracle/app/oracle/product/client10g/rdbms/demo -I/opt/oracle/app/oracle/product/client10g/plsql/public -I/usr/include/pspell -I/root/php-5.2.3/TSRM -I/root/php-5.2.3/Zend -I/root/php-5.2.3/ext/oci8 -D_REENTRANT -I/usr/include -g -pthread -O0 -Wall -DZTS -c /root/php-5.2.3/ext/oci8/oci8.c  -fPIC -DPIC -o ext/oci8/.libs/oci8.o
In file included from /root/php-5.2.3/ext/oci8/oci8.c:50:
/root/php-5.2.3/ext/oci8/php_oci8_int.h:56:17: error: oci.h: No such file or directory
In file included from /root/php-5.2.3/ext/oci8/oci8.c:50:
/root/php-5.2.3/ext/oci8/php_oci8_int.h:101: error: expected specifier-qualifier-list before 'OCIEnv'
/root/php-5.2.3/ext/oci8/php_oci8_int.h:124: error: expected specifier-qualifier-list before 'dvoid'
/root/php-5.2.3/ext/oci8/php_oci8_int.h:136: error: expected specifier-qualifier-list before 'ub4'
.
.
.
.
.




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-09-25 17:05 UTC] sixd@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


--------------------
(i) I appreciate you have a problem
(ii) I am grateful you took the time to report it
(iii) But there is no indication this is a bug.  It looks like a support question and should be asked somewhere else, e.g. http://www.oracle.com/technology/forums/php.html
(iv) You don't include enough supporting information to diagnose what is happening
(v) If you are using the full Oracle Client you possibly have a permission problem, since it installs with restrictive permissions
(vi) I can install PHP 5.2.4 using the full Oracle Client
---------------------
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Nov 27 13:03:48 2022 UTC