php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42724 swedish characters don't work
Submitted: 2007-09-21 11:46 UTC Modified: 2007-11-25 18:24 UTC
From: hannes at knowingweb dot com Assigned:
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS: win
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: hannes at knowingweb dot com
New email:
PHP Version: OS:

 

 [2007-09-21 11:46 UTC] hannes at knowingweb dot com
Description:
------------
The online documentation http://www.php.net/manual/sv/ is not properly formatted for utf-8. ?,?,? are sometimes ok but many times not. I've tried moth IE 6 and Firefox and it's the same in both.

I suppose the reason is that these files either has been made in a non-utf-8 format (or with the BOM?) and installed on server or that they were written via a form by a client using a character set that could not be understood by the server?

I would be interested to know why and if you need help to straighten it up please mail me. (It doesn't look good to a swedish audience with a documentation that can't handle this fundamental matters.)

Regards,

Hannes R?hl

PS I post a source example from the beginning of the file http://www.php.net/manual/sv/index.php where the letter "?" (å) is written correctly and not. I'm not certain thoutgh if it will be visible to you.

Reproduce code:
---------------
[...]

>Inneh?llsf?rteckning</B

[...]

>Komma ig&#65533;ng</A

[...]


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-09-21 12:10 UTC] hannes at knowingweb dot com
From reading my report I see the Unicode number is fffd which is a character used to replace an incoming character whose value is unknown or unrepresentable to Unicode.

So I gather the problem is due to the communication between a client and the server where the client uses a character set or encoding that the server doesn't understand.
 [2007-11-25 18:24 UTC] bjori@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jul 12 22:01:25 2020 UTC