php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42723 array(int, int, ...) to <xsd:sequence> conversion
Submitted: 2007-09-21 09:24 UTC Modified: 2007-09-21 11:20 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: x dot meglio at gmail dot com Assigned:
Status: Not a bug Package: SOAP related
PHP Version: 5.2.4 OS: Windows XP SP2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: x dot meglio at gmail dot com
New email:
PHP Version: OS:

 

 [2007-09-21 09:24 UTC] x dot meglio at gmail dot com
Description:
------------
Array of integers was not converted properly (and not passed as parameter) when using SoapClient in WSDL mode and calling method which take this parameter:

<xsd:complexType name="ArrayOfInt">
  <xsd:sequence>
    <xsd:element form="qualified" maxOccurs="unbounded"
      name="int" nillable="true"  type="xsd:int"/>
  </xsd:sequence>
</xsd:complexType>

Reproduce code:
---------------
I'm calling getAllMarkets method of Betfair.com API (ver. 5.4) and I can't provide whole code because of API login/password of my customer.

I'm calling the method:

MySoapClient->getAllMarkets($request);

where

$request = Array('request' => Array(
  'eventTypesIds' => Array(7),
  'header' => Array('clientStamp' => 0, 'sessionToken' => ...)))

The eventTypesIds parameter of getAllMarkets function takes this type (described in WSDL):

<xsd:complexType name="ArrayOfInt">
  <xsd:sequence>
    <xsd:element form="qualified" maxOccurs="unbounded"
      name="int" nillable="true"  type="xsd:int"/>
  </xsd:sequence>
</xsd:complexType>

P.S. I have reproduced the code in c# and it works well, so the error is just in type transformation in PHP SAOP implementation.

Expected result:
----------------
I expect the market data filtered by specified eventTypesIds (for example, only Horse Racing todays card with ID=13).

Actual result:
--------------
I get the market data for all events (eventTypesIds which I pass to the getAllMarkets does not affect).

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-09-21 11:20 UTC] rrichards@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Jan 28 02:05:53 2023 UTC