php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42717 Perl Interpreter Problem
Submitted: 2007-09-20 15:40 UTC Modified: 2007-09-20 15:48 UTC
From: dbergeron at exec-i dot com Assigned:
Status: Not a bug Package: Performance problem
PHP Version: 5.2.4 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dbergeron at exec-i dot com
New email:
PHP Version: OS:

 

 [2007-09-20 15:40 UTC] dbergeron at exec-i dot com
Description:
------------
Our project uses the Perl Interpreter to access a Perl package
that returns an array reference that will be displayed by a PHP class.

The problem is that the Perl Interpreter attempts to free non-existent shared strings during global destruction.
This dumps over 12,000 lines of text into the Apache log and
impacts performance.

Reproduce code:
---------------
$perl = new Perl();

try {
  $perl->eval('use lib "includes/modules/";');
  $perl->eval('use Assessment;');
  $dAr=$perl->{"Assessment::report"}($_POST);
}
catch (PerlException $exception) {
  echo "Perl Error: " . $exception->getMessage();
}

Assessment is a Perl package that queries a DB2 database and
returns data that is displayed in the browser.

Expected result:
----------------
The apache log file without all the error messages

Actual result:
--------------
Over 12,000 lines of text in the apache log file that look like this:

Attempt to free non-existent shared string 'exe_ext' during global destruction.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-09-20 15:48 UTC] scottmac@php.net
Report bugs for PECL extensions on the PECL bug tracker.

http://pecl.php.net/perl/
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 10 02:01:24 2020 UTC