php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42716 wrong apache version shown in phpinfo() or $_SERVER['SERVER_SOFTWARE']
Submitted: 2007-09-20 14:02 UTC Modified: 2007-09-20 15:43 UTC
From: zen dot kato at google dot com Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 5.2.4 OS: fedora 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: zen dot kato at google dot com
New email:
PHP Version: OS:

 

 [2007-09-20 14:02 UTC] zen dot kato at google dot com
Description:
------------
phpinfo() shows Apache/2.2.0 (Fedora) as Apache Version of
apache2handler.

<?php
echo $_SERVER['SERVER_SOFTWARE'];
?>
shows Apache/2.2.0

under the following sytem:

fedora 7 (2.6.22.5-76.fc7)
php-5.2.4-1.fc7
httpd-2.2.6-1.fc7

this is the same as bug#21220.

Expected result:
----------------
Apache/2.2.6

Actual result:
--------------
Apache/2.2.0

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-09-20 15:43 UTC] scottmac@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

SERVER_SOFTWARE comes from an environmental variable on the Apache process, nothing to do with PHP here.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Feb 28 12:01:27 2024 UTC