php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42709 $_SERVER['PHP_SELF'] provides wrong values
Submitted: 2007-09-19 11:39 UTC Modified: 2007-09-19 13:18 UTC
From: sarith at securehosting dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.2.4 OS: Windows Server 2003 IIS 6.0 CGI
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sarith at securehosting dot com
New email:
PHP Version: OS:

 

 [2007-09-19 11:39 UTC] sarith at securehosting dot com
Description:
------------
Wrong output of PHP_SELF directive when PHP was upgraded to 5.2.4
This directive works fine on 5.2.2 and 5.2.3

Reproduce code:
---------------
For a script 
https://www.somedomain.com/test/index.php 
with the following code:

echo $_SERVER['PHP_SELF'];

Expected result:
----------------
/phpinteractive/index.php

Actual result:
--------------
/phpinteractive/index.php/phpinteractive/index.php

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-09-19 13:18 UTC] jani@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

Already fixed in CVS too.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 17 05:05:45 2022 UTC