php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42702 sapi/cli not getting linked
Submitted: 2007-09-18 15:24 UTC Modified: 2007-09-27 01:00 UTC
Votes:4
Avg. Score:4.5 ± 0.9
Reproduced:3 of 3 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (33.3%)
From: to2958 at att dot com Assigned:
Status: No Feedback Package: Compile Failure
PHP Version: 5.2.4 OS: AIX 4.3.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: to2958 at att dot com
New email:
PHP Version: OS:

 

 [2007-09-18 15:24 UTC] to2958 at att dot com
Description:
------------
I'm using the snapshot php5.2-200709181230:
I can run configure and make without any obvious errors. However when i run make test I get this:
        echo '\
\

Build complete.
Don't forget to run 'make test'.

ERROR: Cannot run tests without CLI sapi.

When I look around I can not find any php executable which was created. I looked at the tail of the make log I see when the cli files were compiled but not linking step ?
...
creating a temporary reloadable object file: .libs/libphp5.la-2.o
        /bin/sh /usr/local/source/php5.2-200709181230/libtool --silent --preserve
-dup-deps --mode=compile /usr/bin/cc_r  -Isapi/cli/ -I/usr/local/source/php5.2-20
0709181230/sapi/cli/ -DPHP_ATOM_INC -I/usr/local/source/php5.2-200709181230/inclu
de -I/usr/local/source/php5.2-200709181230/main -I/usr/local/source/php5.2-200709
181230 -I/usr/local/include/libxml2 -I/usr/local/ssl/include -I/usr/local/source/
php5.2-200709181230/ext/date/lib -I/usr/local/source/php5.2-200709181230/TSRM -I/
usr/local/source/php5.2-200709181230/Zend    -I/usr/include -g   -c /usr/local/so
urce/php5.2-200709181230/sapi/cli/php_cli.c -o sapi/cli/php_cli.lo 
"/usr/local/source/php5.2-200709181230/TSRM/tsrm_config_common.h", line 25.1: 150
6-224 (I) Incorrect #pragma ignored.
        /bin/sh /usr/local/source/php5.2-200709181230/libtool --silent --preserve
-dup-deps --mode=compile /usr/bin/cc_r  -Isapi/cli/ -I/usr/local/source/php5.2-20
0709181230/sapi/cli/ -DPHP_ATOM_INC -I/usr/local/source/php5.2-200709181230/inclu
de -I/usr/local/source/php5.2-200709181230/main -I/usr/local/source/php5.2-200709
181230 -I/usr/local/include/libxml2 -I/usr/local/ssl/include -I/usr/local/source/
php5.2-200709181230/ext/date/lib -I/usr/local/source/php5.2-200709181230/TSRM -I/
usr/local/source/php5.2-200709181230/Zend    -I/usr/include -g   -c /usr/local/so
urce/php5.2-200709181230/sapi/cli/php_cli_readline.c -o sapi/cli/php_cli_readline
.lo 
"/usr/local/source/php5.2-200709181230/TSRM/tsrm_config_common.h", line 25.1: 150
6-224 (I) Incorrect #pragma ignored.
        /bin/sh /usr/local/source/php5.2-200709181230/libtool --silent --preserve
-dup-deps --mode=compile /usr/bin/cc_r  -Isapi/cli/ -I/usr/local/source/php5.2-20
0709181230/sapi/cli/ -DPHP_ATOM_INC -I/usr/local/source/php5.2-200709181230/inclu
de -I/usr/local/source/php5.2-200709181230/main -I/usr/local/source/php5.2-200709
181230 -I/usr/local/include/libxml2 -I/usr/local/ssl/include -I/usr/local/source/
php5.2-200709181230/ext/date/lib -I/usr/local/source/php5.2-200709181230/TSRM -I/
usr/local/source/php5.2-200709181230/Zend    -I/usr/include -g   -c /usr/local/so
urce/php5.2-200709181230/sapi/cli/getopt.c -o sapi/cli/getopt.lo 
"/usr/local/source/php5.2-200709181230/TSRM/tsrm_config_common.h", line 25.1: 150
6-224 (I) Incorrect #pragma ignored.
        /bin/sh /usr/local/source/php5.2-200709181230/libtool --silent --preserve
-dup-deps --mode=compile /usr/bin/cc_r  -Imain/ -I/usr/local/source/php5.2-200709
181230/main/ -DPHP_ATOM_INC -I/usr/local/source/php5.2-200709181230/include -I/us
r/local/source/php5.2-200709181230/main -I/usr/local/source/php5.2-200709181230 -
I/usr/local/include/libxml2 -I/usr/local/ssl/include -I/usr/local/source/php5.2-2
00709181230/ext/date/lib -I/usr/local/source/php5.2-200709181230/TSRM -I/usr/loca
l/source/php5.2-200709181230/Zend    -I/usr/include -g   -c main/internal_functio
ns_cli.c -o main/internal_functions_cli.lo 
"/usr/local/source/php5.2-200709181230/TSRM/tsrm_config_common.h", line 25.1: 150
6-224 (I) Incorrect #pragma ignored.
        echo '\
\

Build complete.
Don't forget to run 'make test'.

I'm trying to solve this myself but thought it might be something simple. I didn't find anything in the bug base nor the maillist which seem like this.

Thanks!
Todd

Expected result:
----------------
I'm expecting there to be a php executable for the test phase.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-09-19 08:09 UTC] jani@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 [2007-09-27 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Apr 15 03:01:28 2024 UTC