php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42687 cannot use php_mssql.dll under php5isapi.dllw with IIS 6.0
Submitted: 2007-09-17 12:32 UTC Modified: 2007-09-18 09:33 UTC
From: support at fox-it dot dk Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 5.2.4 OS: Windows 2003 x64 ServicePack 2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: support at fox-it dot dk
New email:
PHP Version: OS:

 

 [2007-09-17 12:32 UTC] support at fox-it dot dk
Description:
------------
Upgraded php v5.2.3 -> v5.2.4. Making as script calling mssql_functions eg. mssql_connect works when running php.exe script.php. a phpinfo also show mssql extension is active when run via commandline, but not when loaded viap php5isapi, other extensions such as mysqli works fine.

PHP is in the systempath. Tried with bundled ntwdblib and with version 8.0.2187 (postsp4 fix). IIS is running in 32-bit mode and it did work with php v5.2.3
 




Reproduce code:
---------------
<?php
$link =  mssql_connect('server', 'username', 'password');
?>

Expected result:
----------------
mssql_connectan other mssql_functions works.

Actual result:
--------------
Fatal error: Call to undefined function mssql_connect() in W:\Inetpub\dashboardtest.idenyt.dk\john.php on line 4

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-09-18 09:33 UTC] jani@php.net
Obviously the extension isn't loaded due to some installation failure. I suggest you do this from clean board: remove old PHP installation (everything!) and then reinstall 5.2.4. Works fine for me..
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jan 18 08:03:18 2022 UTC