php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42677 PHP converts all dot(.) in from field names to Underscore(_)
Submitted: 2007-09-15 17:00 UTC Modified: 2007-09-15 19:28 UTC
From: neel dot basu dot z at gmail dot com Assigned:
Status: Not a bug Package: Filter related
PHP Version: 5.2.4 OS: Debian
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: neel dot basu dot z at gmail dot com
New email:
PHP Version: OS:

 

 [2007-09-15 17:00 UTC] neel dot basu dot z at gmail dot com
Description:
------------
If form field name contains any dot(.) PHP automatically 
Stores it into $_POST variable after converting all dots to _


Reproduce code:
---------------
<?php
if(count($_POST) > 0){
print_r($_POST);
}
?>
<form method="POST" action="">
<input type="text" name="a.b" value="Sample" />
<input type="Submit" name="submit" value="Submit">
</form>

Expected result:
----------------
Array
( 
  [a.b] => Sample 
  [submit] => Submit
)

Actual result:
--------------
Array
( 
  [a_b] => Sample 
  [submit] => Submit
)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-09-15 19:28 UTC] scottmac@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

with register_globals on $a.b wouldn't be a valid variable name, so this is expected behavior.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jan 20 02:03:35 2022 UTC