php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42676 New PHP 5.2.4 install -> "PHP has encountered an Access Violation at 0131903A"
Submitted: 2007-09-15 01:31 UTC Modified: 2007-09-26 01:00 UTC
Votes:5
Avg. Score:3.8 ± 1.0
Reproduced:3 of 4 (75.0%)
Same Version:3 (100.0%)
Same OS:3 (100.0%)
From: jswift at usc dot edu Assigned:
Status: No Feedback Package: IIS related
PHP Version: 5.2.4 OS: IIS6 Windows Server 2006
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jswift at usc dot edu
New email:
PHP Version: OS:

 

 [2007-09-15 01:31 UTC] jswift at usc dot edu
Description:
------------
Hello,
I trying a new PHP 5.2.4 on Windows Server 2006 II6. I have followed all of the installation notes I could find, and I always get this error:  "PHP has encountered an Access Violation at 0131903A", or some other # at the end. I have tried:
1) setting all the paths in the PHP.ini file so IUSR has write permissions
2) turned my firewall off
3) copied PHP.ini to c:\windows
4) set environtal variable, etc. as per instructions on this website

Can anyone point me to a good set of installation notes? The ones on this website are not sufficient.

Thank you, J.


Reproduce code:
---------------
<html>
<body>

  <?php

  print ("I am the CHICKEN MAN");

  ?>

</body>
</html>

Expected result:
----------------
I am the CHICKEN MAN

Actual result:
--------------
PHP has encountered an Access Violation at blah blah blah...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-09-15 15:03 UTC] jelly_bean_junky at hotmail dot com
I have the same problem:
Windows Server 2003
IIS6 (all service packs and pacthes installed)
PHP 5.2.4

I have tried older versions, newer versions, adding permissions to directories and just about everything else.
I also tried the versions from the snaps.php.net too.

None of these work. I've seen for the same 5.2 branch alot of people have the same problem.
 [2007-09-18 10:38 UTC] jani@php.net
1. Delete ALL existing PHP related dlls/etc. before installing new version. 
2. If problem persists, try using CGI/FastCGI binary instead of the unmaintained ISAPI module.
 [2007-09-26 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 16:03:34 2021 UTC