php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4266 Undeclared variables in function/imap.c starting ar line 435
Submitted: 2000-04-28 04:14 UTC Modified: 2002-10-01 03:06 UTC
From: david at polinsky dot com Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 3.0.16 OS: linux (redhat 6.2)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: david at polinsky dot com
New email:
PHP Version: OS:

 

 [2000-04-28 04:14 UTC] david at polinsky dot com
step=php.1
logmesg=/data/install/logs/m$step
cat /data/install/shells/$step | tee $logmesg && \
date | tee -a $logmesg && \
./configure \
	--with-apxs=/usr/local/apache/bin/apxs \
	--with-apache=/usr/local/apache/bin/httpd \
	--with-config-file-path=/etc/httpd \
	--with-gd=/usr/local \
	--with-imap=/usr \
	--with-mysql=/usr/local/mysql \
	--with-ldap=/usr/local \
	--with-zlib \
	--with-xml \
	--enable-track-vars \
2>&1 | tee -a $logmesg && \
date | tee -a $logmesg
Thu Apr 27 21:59:19 EDT 2000
creating cache ./config.cache
checking whether build environment is sane... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for bison... bison -y
checking bison version... 1.28 (ok)
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for ranlib... ranlib
checking whether gcc and cc understand -c and -o together... yes
checking whether ln -s works... yes
checking for perl... /usr/bin/perl
checking for sh... /bin/sh
checking for working const... yes
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking if compiler supports -Wl,--version-script... yes
checking size of long... 4
checking size of int... 4
checking for sendmail... /usr/sbin/sendmail
checking for gethostent... yes
checking for socket in -lc... yes
checking for gethostbyaddr in -lc... yes
checking for crypt in -lc... no
checking for crypt in -lcrypt... yes
checking for dlopen in -lc... no
checking for dlopen in -ldl... yes
checking for sin in -lc... no
checking for sin in -lm... yes
checking for res_search in -lsocket... no
checking for res_search in -lresolv... yes
checking for pam_start in -lpam... yes
checking for inet_aton in -lbind... no
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for dirent.h that defines DIR... yes
checking for opendir in -ldir... no
checking for fclose declaration... ok
checking for fcntl.h... yes
checking for unistd.h... yes
checking for crypt.h... yes
checking for sys/file.h... yes
checking for memory.h... yes
checking for pwd.h... yes
checking for grp.h... yes
checking for sys/socket.h... yes
checking for sys/wait.h... yes
checking for syslog.h... yes
checking for string.h... yes
checking for sys/varargs.h... no
checking for stdarg.h... yes
checking for sys/resource.h... yes
checking for sys/time.h... yes
checking for signal.h... yes
checking for netinet/in.h... yes
checking for dlfcn.h... yes
checking for limits.h... yes
checking for sys/types.h... yes
checking for sys/statvfs.h... yes
checking for sys/statfs.h... yes
checking for unix.h... no
checking for db.h... yes
checking for dbm.h... no
checking for ndbm.h... no
checking for db1/ndbm.h... yes
checking for locale.h... yes
checking for features.h... yes
checking whether struct tm is in sys/time.h or time.h... time.h
checking for tm_zone in struct tm... yes
checking for tm_gmtoff in struct tm... yes
checking for struct flock... yes
checking for st_blksize in struct stat... yes
checking for st_blocks in struct stat... yes
checking for st_rdev in struct stat... yes
checking for size_t... yes
checking for uid_t in sys/types.h... yes
checking for uint... yes
checking for ushort... yes
checking for ulong... yes
checking for ptrdiff_t... yes
checking for vprintf... yes
checking for memcpy... yes
checking for memmove... yes
checking for strdup... yes
checking for strerror... yes
checking for strcasecmp... yes
checking for strstr... yes
checking for flock... yes
checking for lockf... yes
checking for putenv... yes
checking for tempnam... yes
checking for usleep... yes
checking for setlocale... yes
checking for gettimeofday... yes
checking for setvbuf... yes
checking for srand48... yes
checking for lrand48... yes
checking for srandom... yes
checking for random... yes
checking for link... yes
checking for symlink... yes
checking for regcomp... yes
checking for getlogin... yes
checking for cuserid... yes
checking for vsnprintf... yes
checking for gcvt... yes
checking for utime... yes
checking for crypt... yes
checking for setitimer... yes
checking for rint... yes
checking for unsetenv... yes
checking for strftime... yes
checking for setsockopt... yes
checking for tzset... yes
checking for statvfs... yes
checking for statfs... yes
checking for inet_aton... yes
checking for shutdown... yes
checking for truncate... yes
checking for getpgid... yes
checking for getsid... yes
checking for getrlimit... yes
checking for snprintf... yes
checking for ctermid... yes
checking for setsid... yes
checking for mkfifo... yes
checking for getrusage... yes
checking whether utime accepts a null argument... yes
checking for working alloca.h... yes
checking for alloca... yes
checking for broken sprintf... ok
checking for getopt... yes
checking for declared timezone... yes
checking for standard DES crypt... yes
checking for extended DES crypt... no
checking for MD5 crypt... yes
checking for Blowfish crypt... no
checking for Apache module support via DSO through APXS... yes
checking whether to enable versioning... no
checking whether to use bundled regex library... yes
checking for gdbm_open in -lgdbm... no
checking for dbm_open in -ldb... yes
checking preferred dbm library... ndbm chosen
checking for mod_charset compatibility option... no
checking for fhttpd module support... no
checking for IMAP support... yes
checking for IMSP support... no
checking for ASPELL support... no
checking for MCAL support... no
checking for ftp support... no
checking for compress in -lz... yes
checking for png_info_init in -lpng... yes
checking for gdImageCreateFromPng in -lgd... yes
checking for gdImageCreateFromJpeg in -lgd... no
checking for gdImageCreateFromGif in -lgd... no
checking for gdImageLzw in -lgd... no
checking for gdImageColorResolve in -lgd... yes
checking for gdImageString16 in -lgd... yes
checking whether to include GD support... yes
checking whether to include FreeType support... yes
checking whether to enable t1lib support... no
checking whether to include GNU gettext support... no
checking whether to include ImageMagick support... no
checking for Oracle support... no
checking for iODBC support... no
checking for OpenLink ODBC support... no
checking for Adabas support... no
checking for Sybase support... no
checking for Sybase-CT support... no
checking for MySQL support... yes
checking for errmsg.h... yes
checking for mysql.h... yes
checking for mSQL support... no
checking for PostgresSQL support... no
checking for IBM DB2 support... no
checking for Solid support... no
checking for Empress support... no
checking for LDAP support... yes
checking for Cybercash MCK support... no
checking for SNMP support... no
checking whether to enable UCD SNMP hack... no
checking for Velocis support... no
checking for Informix support... no
checking for InterBase support... no
checking for a custom ODBC support... no
checking for Hyperwave support... no
checking for XML support... yes
checking whether to include YP support... no
checking whether to include zlib support... yes
checking for gzgets in -lz... yes
checking whether to include pdflib support... no
checking whether to include cpdflib support... no
checking whether to include fdftk support... no
checking whether to include the bundled dbase library... no
checking whether to include the bundled filePro support... no
checking whether to enable DAV support through mod_dav... no
checking whether to enable unified ODBC support... no
checking whether to use a configuration file... yes
checking whether to include debugging symbols... no
checking whether to enable safe mode by default... no
checking for safe mode exec dir... /usr/local/php/bin
checking whether to enable track_vars variables by default... yes
checking whether to enable magic quotes by default... no
checking whether to enable remote debugger support... no
checking whether to enable bc style precision math functions... yes
checking whether to enable a memory limit... no
checking whether to enable short tags by default... yes
checking whether to enable the URL-aware fopen wrapper... yes
checking whether to enable System V semaphore support... no
checking whether to enable System V shared memory support... no
checking whether to enable displaying source support... yes
checking for GDBM support... no
checking for NDBM support... no
checking for Berkeley DB2 support... no
checking for DBM support... no
checking for CDB support... no
checking whether to enable DBA interface... no
checking for mcrypt support... no
checking for mhash support... no
checking whether to include PCRE support... yes
checking for memmove... (cached) yes
checking whether to include POSIX support... yes
checking whether to include GNU recode support... no
checking whether to enable dmalloc support... no
checking for __dn_skipname in -lbind... no
updating cache ./config.cache
creating ./config.status
creating Makefile
creating build-defs.h
creating stamp-h
creating libphp3.module
creating extra/gd/bdf2gdfont
creating regex/Makefile
creating pcrelib/Makefile
creating dbase/Makefile
creating config.h
Thu Apr 27 22:00:01 EDT 2000


step=php.2
logmesg=/data/install/logs/m$step
cat /data/install/shells/$step | tee $logmesg && \
date | tee -a $logmesg && \
make  \
2>&1 | tee -a $logmesg && \
date | tee -a $logmesg
Thu Apr 27 22:00:07 EDT 2000
bison -y -p php -v -d ./language-parser.y -o language-parser.tab.c
gcc -g -O2 -DLINUX=2 -DMOD_SSL=206103 -DUSE_HSREGEX -DEAPI -DEAPI_MM -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED -O2 -fpic -DSHARED_MODULE  -I. -I.   -I/usr/local/apache/include                  -I/usr/local/include -I/usr/local/mysql/include/mysql -I/usr/local/apache/include    -c language-parser.tab.c -o language-parser.tab.o
flex -Pphp -olanguage-scanner.c -i ./language-scanner.lex
gcc -g -O2 -DLINUX=2 -DMOD_SSL=206103 -DUSE_HSREGEX -DEAPI -DEAPI_MM -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED -O2 -fpic -DSHARED_MODULE  -I. -I.   -I/usr/local/apache/include                  -I/usr/local/include -I/usr/local/mysql/include/mysql -I/usr/local/apache/include    -w -DYY_USE_CONST -c language-scanner.c
gcc -g -O2 -DLINUX=2 -DMOD_SSL=206103 -DUSE_HSREGEX -DEAPI -DEAPI_MM -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED -O2 -fpic -DSHARED_MODULE  -I. -I.   -I/usr/local/apache/include                  -I/usr/local/include -I/usr/local/mysql/include/mysql -I/usr/local/apache/include    -c main.c -o main.o

<SNIP a lot of gcc compiles that appeared to work>

gcc -g -O2 -DLINUX=2 -DMOD_SSL=206103 -DUSE_HSREGEX -DEAPI -DEAPI_MM -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED -O2 -fpic -DSHARED_MODULE  -I. -I.   -I/usr/local/apache/include                  -I/usr/local/include -I/usr/local/mysql/include/mysql -I/usr/local/apache/include    -c debugger.c -o debugger.o
bison -y -p cfg -v -d ./configuration-parser.y -o configuration-parser.tab.c
gcc -g -O2 -DLINUX=2 -DMOD_SSL=206103 -DUSE_HSREGEX -DEAPI -DEAPI_MM -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED -O2 -fpic -DSHARED_MODULE  -I. -I.   -I/usr/local/apache/include                  -I/usr/local/include -I/usr/local/mysql/include/mysql -I/usr/local/apache/include    -c configuration-parser.tab.c -o configuration-parser.tab.o
flex -Pcfg -oconfiguration-scanner.c -i ./configuration-scanner.lex
gcc -g -O2 -DLINUX=2 -DMOD_SSL=206103 -DUSE_HSREGEX -DEAPI -DEAPI_MM -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED -O2 -fpic -DSHARED_MODULE  -I. -I.   -I/usr/local/apache/include                  -I/usr/local/include -I/usr/local/mysql/include/mysql -I/usr/local/apache/include    -w -DYY_USE_CONST -c configuration-scanner.c

<SNIP a lot of gcc compiles that appeared to work>

gcc -g -O2 -DLINUX=2 -DMOD_SSL=206103 -DUSE_HSREGEX -DEAPI -DEAPI_MM -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED -O2 -fpic -DSHARED_MODULE  -I. -I.   -I/usr/local/apache/include                  -I/usr/local/include -I/usr/local/mysql/include/mysql -I/usr/local/apache/include    -c functions/imap.c -o functions/imap.o
functions/imap.c: In function `imap_init':
functions/imap.c:435: `unixdriver' undeclared (first use in this function)
functions/imap.c:435: (Each undeclared identifier is reported only once
functions/imap.c:435: for each function it appears in.)
functions/imap.c:437: `imapdriver' undeclared (first use in this function)
functions/imap.c:438: `nntpdriver' undeclared (first use in this function)
functions/imap.c:439: `pop3driver' undeclared (first use in this function)
functions/imap.c:441: `mhdriver' undeclared (first use in this function)
functions/imap.c:442: `mxdriver' undeclared (first use in this function)
functions/imap.c:444: `mbxdriver' undeclared (first use in this function)
functions/imap.c:445: `tenexdriver' undeclared (first use in this function)
functions/imap.c:446: `mtxdriver' undeclared (first use in this function)
functions/imap.c:448: `mmdfdriver' undeclared (first use in this function)
functions/imap.c:449: `newsdriver' undeclared (first use in this function)
functions/imap.c:450: `philedriver' undeclared (first use in this function)
functions/imap.c:452: `dummydriver' undeclared (first use in this function)
functions/imap.c:453: `auth_log' undeclared (first use in this function)
make: *** [functions/imap.o] Error 1
Thu Apr 27 22:01:50 EDT 2000

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-30 19:52 UTC] hholzgra@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 [2002-09-30 21:44 UTC] root at localhost dot com
Your bug support leaves a lot to be desired. You require a password that doesn't exist. This is what you emailed to me.
"The password for bug report #4266 is ."
The bug you commented on was reported over 2 years ago and the best comment you can give is that I'm not using the current version. You could at least have recognized that there was a two-year delay and that I wasn't using the current version, because it didn't exist when I reported the bug.
Better still, you could just have continued to ignore the bug, since I don't give a damn about it anymore.
 [2002-10-01 02:58 UTC] hholzgra@php.net
> Your bug support leaves a lot to be desired. 
> You require a password that
> doesn't exist. This is what you emailed to me.
> "The password for bug report #4266 is ."

this is indeed a bug ... :(



> The bug you commented on was reported over 2 years 
> ago and the best comment you can give is that I'm 
> not using the current version. You could at least have 
> recognized that there was a two-year delay and that
> I wasn't using the current version, because it 
> didn't exist when I reported the bug.

i could have also selected the "not a developer issue,
ask php-general@ mailing list instead"

i've been using imap extensively back then and it *did*
compile on redhat, provided that the right imap c-client
header files were installed, and i'm rather sure the 
documentation was already telling about it back then

but the build system has been improved since then so
it might be that it is now able to figure out whats
wrong itself, so trying again with a recent version 
would not harm

> Better still, you could just have continued to 
> ignore the bug, since I don't give a damn about 
> it anymore.

sorry for taking the time to clean things up,
was thinking "better late then never"
 [2002-10-01 03:06 UTC] yohgaki@php.net
I guess we need to write a little program that send e-mail 
"Please check CVS version see if it is fixed" every 6 month or so.

There are many bugs that are fixed, but not closed.

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jan 29 07:01:23 2020 UTC