php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42574 unknow configure option (good in 5.2.3)
Submitted: 2007-09-06 08:43 UTC Modified: 2007-09-06 08:55 UTC
From: bernard dot prevosto at ifremer dot fr Assigned: pajoye (profile)
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.2.4 OS: solaris 5.8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bernard dot prevosto at ifremer dot fr
New email:
PHP Version: OS:

 

 [2007-09-06 08:43 UTC] bernard dot prevosto at ifremer dot fr
Description:
------------
Thank you for using PHP.

warning at the end of configure

no warning with PHP-5.2.3

Reproduce code:
---------------
my configure file:

./configure \
--with-apache=/home1/balanec/perso/bpre/anonymous/apache/apache_1.3.37 \
--with-ldap=/home/services/bibli/openldap \
--with-mysql=/home/services/bibli/mysql \
--with-pgsql=/home/services/bibli/www/pgsql \
--with-sybase=/home/services/bibli/www/sybase \
--with-oracle=/home/services/bibli/www/ora920 \
--with-oci8=/home/services/bibli/www/ora920 \
--with-gd \
--with-zlib-dir=/home/services/bibli/zlib \
--with-zip=/home/services/bibli/zziplib \
--with-jpeg-dir=/home/services/bibli/jpeglib \
--with-png-dir=/home/services/bibli/pnglib \
--with-tiff-dir=/home/services/bibli/tifflib \
--with-pdflib=/home/services/bibli/pdflib \
--with-imap=/home/services/bibli/www/imap \
--with-snmp=/home/services/systeme/reseau/ucd-snmp \
--with-mcrypt=/home/services/bibli/mcryptlib \
--with-sablot=/home/services/bibli/sablotlib-1.0.3 \
--with-expat-dir=/home/services/bibli/expatlib \
--with-xslt-sablot=/home/services/bibli/sablotlib-1.0.3 \
--with-gettext=/home/services/logiciels/gettext \
--with-dom=/home/services/bibli/xmllib \
--with-dom-xslt=/home/services/bibli/xsltlib \
--with-libxml-dir=/home/services/bibli/xml2lib \
--with-xsl=/home/services/bibli/xsltlib \
--with-curl=/home/services/logiciels/curl \
--with-iconv \
--enable-soap \
--enable-sysvsem \
--enable-sysvshm \
--enable-calendar \
--enable-mbstring=all \
--enable-exif \
--enable-xslt \
--without-pear \
--disable-cli \
--disable-pdo \
--with-config-file-path=/home/services/bibli/www/php



at the end of configure I've the message:





Thank you for using PHP.

Notice: Following unknown configure options were used:

--with-oracle=/home/services/bibli/www/ora920
--with-zip=/home/services/bibli/zziplib
--with-tiff-dir=/home/services/bibli/tifflib
--with-pdflib=/home/services/bibli/pdflib
--with-sablot=/home/services/bibli/sablotlib-1.0.3
--with-expat-dir=/home/services/bibli/expatlib
--with-xslt-sablot=/home/services/bibli/sablotlib-1.0.3
--with-dom=/home/services/bibli/xmllib
--with-dom-xslt=/home/services/bibli/xsltlib
--enable-xslt

Check './configure --help' for available options



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-09-06 08:55 UTC] pajoye@php.net
"--with-zip=/home/services/bibli/zziplib"

This option does not exist anymore (and not in 5.2.3 either). If you like to have the ext/zip support, use "--enable-zip"

For the other options, they simply don't exist anymore. They are mostly php4 options, the extensions are either not available anymore or has been completely rewritten, see configure --help and the php manuals to get more information.

Not a bug > bogus.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Aug 15 23:05:44 2022 UTC