php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42494 Exemple of your web site page "lang - IT"
Submitted: 2007-08-31 13:38 UTC Modified: 2007-09-01 09:27 UTC
From: alberto dot bravi at f3arless dot com Assigned:
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS: mac os x
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: alberto dot bravi at f3arless dot com
New email:
PHP Version: OS:

 

 [2007-08-31 13:38 UTC] alberto dot bravi at f3arless dot com
Description:
------------
Hi,

in http://it.php.net/manual/it/function.system.php

the first exemple have a error, in Italian language.

Reproduce code:
---------------
<?php
      echo '<pre>';
      
      // Mette in output tutti i risultati della shellcommand "ls", e restituisce
      // l'ultima  linea di output nella $last_line. Memorizza il valore restituito
      // del comando da shell in $retval.
      $last_line = system('ls', $retval);
      
      // Stampa informazioni aggiuntive
      echo '
      </pre>
      <hr />L'ultima linea dell'output: ' . $last_line . '
      <hr />Restituisce il valore: ' . $retval;
      ?> 

Expected result:
----------------
Parse error: syntax error, unexpected T_STRING, expecting ',' or ';' in PATH OF FILE on line 12

Actual result:
--------------
<?php
      echo '<pre>';
      
      // Mette in output tutti i risultati della shellcommand "ls", e restituisce
      // l'ultima  linea di output nella $last_line. Memorizza il valore restituito
      // del comando da shell in $retval.
      $last_line = system('ls', $retval);
      
      // Stampa informazioni aggiuntive
      echo '
      </pre>
      <hr />L\'ultima linea dell\'output: ' . $last_line . '
      <hr />Restituisce il valore: ' . $retval;
      ?> 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-08-31 15:20 UTC] bjori@php.net
Reclassified.
 [2007-08-31 15:24 UTC] alberto dot bravi at f3arless dot com
Reclassified
 [2007-09-01 09:27 UTC] nlopess@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Apr 10 10:01:24 2020 UTC