php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4248 Unable to run ./configure --with-cdb using cdb v0.75
Submitted: 2000-04-26 12:14 UTC Modified: 2002-11-03 09:25 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: sitz at onastick dot net Assigned: helly (profile)
Status: Closed Package: Installation problem
PHP Version: 4.3.0dev OS: Solaris 2.6
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sitz at onastick dot net
New email:
PHP Version: OS:

 

 [2000-04-26 12:14 UTC] sitz at onastick dot net
./configure checks for cdb_bread when passed --with-cdb. However, the CDB API has changed somewhere between 0.55 (the version that works) and version 0.75 (the version that gave me a couple of hours of headaches ;) ). Enough so that the the check performed by ./configure to see if libcdb.a works now fails. Yay. (note that cdb-0.55 *does* work, with relevant files in the same locations)

My full ./configure line:

./configure \
  --enable-versioning \
  --with-apache=../apache_1.3.12 \
  --with-aspell=/usr/local/include/aspell \
  --with-ftp \
  --with-gd \
  --with-jpeg-dir \
  --with-mysql \
  --with-xml \
  --with-zlib \
  --with-pdflib \
  --with-config-file-path=/usr/local/etc \
  --enable-safe-mode \
  --enable-track-vars \
  --enable-force-cgi-redirect \
  --enable-memory-limit \
  --enable-sysvsem \
  --enable-sysvshm \
  --with-gdbm \
  --with-db2 \
  --with-cdb

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-18 16:00 UTC] colin at easydns dot com
This still doesn't seem to be corrected in PHP 4.3.0-dev, which makes the --with-cdb option pretty much useless.

Could one of the developers maybe look rewriting the PHP code to interface with the CDB 0.75 library?

- Colin
 [2002-11-03 09:25 UTC] helly@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.

I had no problems with installing CDB 0.75 but had to fix the handler. It should work now.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jul 06 22:05:44 2022 UTC