php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #42403 Field Attributes
Submitted: 2007-08-23 21:28 UTC Modified: 2010-06-21 08:57 UTC
From: ssufficool at rov dot sbcounty dot gov Assigned:
Status: Duplicate Package: *General Issues
PHP Version: 5.2.3 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ssufficool at rov dot sbcounty dot gov
New email:
PHP Version: OS:

 

 [2007-08-23 21:28 UTC] ssufficool at rov dot sbcounty dot gov
Description:
------------
The PDO getColumnMeta does not return all of the attributes that the mssql_* functions return using FreeTDS or DBLIB.

Reproduce code:
---------------
<?php
$select = $DB->query('SELECT fruit_name FROM fruit');
$meta = $select->getColumnMeta(0);
var_dump($meta);
?> 





Expected result:
----------------
the proper length, not -1 and type of the character field along with other attributes provided by mssql_field_* functions

Actual result:
--------------
field length of -1 along with other invalid/unknown attributes

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-06-21 08:57 UTC] ssufficool@php.net
-Status: Open +Status: Duplicate -Package: Feature/Change Request +Package: *General Issues
 [2010-06-21 08:57 UTC] ssufficool@php.net
Duplicate of bug #45876
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC