php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4240 --without-config-file-path crashes PhpInfo();
Submitted: 2000-04-25 20:13 UTC Modified: 2002-10-01 16:47 UTC
From: elfchief+phpbug at lupine dot org Assigned:
Status: Wont fix Package: Reproducible Crash
PHP Version: 3.0.16 OS: SunOS eclipse 5.7 Generic_106542
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
43 + 8 = ?
Subscribe to this entry?

 
 [2000-04-25 20:13 UTC] elfchief+phpbug at lupine dot org
It looks like compiling with --without-config-file-path makes PhpInfo() core dump. The relative part of the core:

#0  0x80b3e51 in ap_bputs (x=0x0, fb=0x81856a4) at buff.c:1542
#1  0x80c1673 in ap_rputs (str=0x0, r=0x81dc644) at http_protocol.c:2381
#2  0x8065b75 in php3_puts (s=0x0) at main.c:196
#3  0x8092184 in _php3_info () at functions/info.c:144
#4  0x8093bbb in php3_info (ht=0x82a5f00, return_value=0x814c5d8,
    list=0x8164c00, plist=0x8165660) at functions/info.c:419
#5  0x80a5ab0 in phpparse () at control_structures_inline.h:929
#6  0x806781f in php3_parse (yyin=0x81652e0) at main.c:1540
#7  0x8067a52 in apache_php3_module_main (r=0x81dc644, fd=46,
    display_source_mode=0, preprocessed=0) at main.c:1899


... and line 144 of functions.info.c is:

        PUTS(CONFIGURATION_FILE_PATH);


An actual fix is left as an exercise for the reader.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-01 16:47 UTC] hholzgra@php.net
We are sorry, but can not support PHP 3 related problems anymore.
Momentum is gathering for PHP 5, and we think supporting PHP 3 will
lead to a waste of resources which we want to put into getting PHP 5
ready. Ofcourse PHP 4 will will continue to be supported for the
forseeable future.

php 4 doesn't segfault here, but still the option just doesnt make sense ...
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon May 17 14:01:24 2021 UTC