php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42354 DSN connection not working!
Submitted: 2007-08-20 20:15 UTC Modified: 2007-08-21 07:38 UTC
From: kereteam dot designs at gmail dot com Assigned:
Status: Not a bug Package: ODBC related
PHP Version: 5.2.3 OS: WinXP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: kereteam dot designs at gmail dot com
New email:
PHP Version: OS:

 

 [2007-08-20 20:15 UTC] kereteam dot designs at gmail dot com
Description:
------------
I am trying to access an MS Access DB on the web, I have created a DSN name for it (through the server's control interface).
The connection script works fine on my own personal computer and I can insert and delete records. Not so when I try on the web server.

The DSN name I assigned is KeretlawDB, and it stores the path of the .mdb file on the server (..\db\keretlaw.mdb)

Reproduce code:
---------------
$link = odbc_connect ('KeretlawDB', '', '');
if (!$link) {
	echo "Connection to ODBC failed: ", odbc_errormsg(), "<br>";
} else {
	echo "Connection to ODBC successfull. NO PASSWORD REQUIRED <br>";
}

Expected result:
----------------
There should be a connection established, and I should be able to retrieve / insert information.

Should have echoed:
Connection to ODBC successfull. NO PASSWORD REQUIRED


Actual result:
--------------
Connection to ODBC failed: [Microsoft][ODBC Microsoft Access Driver] The Microsoft Jet database engine cannot open the file '(unknown)'. It is already opened exclusively by another user, or you need permission to view its data.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-08-21 07:38 UTC] jani@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Sep 23 04:01:25 2020 UTC