php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42345 Error in my_thread_global_end(): 1 threads didn't exit
Submitted: 2007-08-20 08:08 UTC Modified: 2007-08-21 21:36 UTC
From: alen dot tot at bauweb dot biz Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 5.2.3 OS: Windows Server 2003 R2 SP2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
27 + 7 = ?
Subscribe to this entry?

 
 [2007-08-20 08:08 UTC] alen dot tot at bauweb dot biz
Description:
------------
Web server is IIS 6,PHP runs as CGI. When I call function mssql_connect() I get php error: Error in my_thread_global_end(): 1 threads didn't exit.When I switch to PHP ISAPI everything is OK.MS SQL server is located on another Win 2003 server.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-08-20 12:32 UTC] alen dot tot at bauweb dot biz
I replaced PHP with PHP and pecl ext. 5.2.4 RC3 dev and mysqllib.dll,ntwdblib.dll  but the error isn't gone.Everything is ok in ISAPI mode
 [2007-08-20 13:00 UTC] jani@php.net
1. Remove EVERYTHING related to old installation.
2. Install everything (including the ISAPI pos) from fresh PHP snapshot.
 [2007-08-20 13:56 UTC] alen dot tot at bauweb dot biz
I removed directory with PHP 5.2.3 and put fresh PHP dev version together with pecl files and than i replaced every dll in windows\system32 with correspond dll version in PHP directory... what else can I do?  ... where is the problem ...php sites with mysql(version 5.0.41 on localhost) works just fine in CGI mode.I repeat MS SQL server is on another win2003 server and ntwdblib.dll on that machine is different version
 [2007-08-20 14:32 UTC] jani@php.net
This is actually duplicate of #41350 so please follow that one instead.

 [2007-08-21 21:36 UTC] alen dot tot at bauweb dot biz
Well I can tell you that I switch to php 5.2.1 version and everything is OK now. mssql_connect() work in ISAPI and CGI/FastCGI mode.
PHP 5.2.3 and PHP 5.2.4 final dev and probably 5.2.2 release reports my_thread_global_end() error when I use mssql_connect() function.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Dec 03 12:03:44 2022 UTC