php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42192 PHP Variable $_GET not correct filled from HTTP Request
Submitted: 2007-08-02 22:46 UTC Modified: 2007-08-03 01:03 UTC
From: michael dot gautschi at gmx dot ch Assigned:
Status: Not a bug Package: URL related
PHP Version: 5.2.3 OS: Windows
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: michael dot gautschi at gmx dot ch
New email:
PHP Version: OS:

 

 [2007-08-02 22:46 UTC] michael dot gautschi at gmx dot ch
Description:
------------
pi.php contains only phpinfo();

When called with 'http://localhost/pi.php?file=%2520B.txt', the value of '_GET["file"]' is '%20B.txt'. Expected was '%2520B.txt'. 

Reproduce code:
---------------
pi.php contains only phpinfo();

When called with 'http://localhost/pi.php?file=%2520B.txt', the value of '_GET["file"]' is '%20B.txt'. Expected was '%2520B.txt'. 

Expected result:
----------------
'$_GET["file"]' is '%2520B.txt'

Actual result:
--------------
'$_GET["file"]' is '%20B.txt'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-08-03 01:03 UTC] jani@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 26 12:05:49 2022 UTC