php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41898 mysqli_* functions missing
Submitted: 2007-07-05 01:09 UTC Modified: 2008-08-26 22:18 UTC
From: ben at popator dot com Assigned:
Status: Not a bug Package: MySQLi related
PHP Version: 5.2.3 OS: CentOS 4.5 x86_64
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: ben at popator dot com
New email:
PHP Version: OS:

 

 [2007-07-05 01:09 UTC] ben at popator dot com
Description:
------------
PHP 5.2.3 fails to implement mysqli functions in conjunction with mysql.

phpinfo() reports MySQL and MySQLi as being available.

Attempted workarounds as detailed at http://www.kofler.cc/forum/forumthread.php?rootID=3571 without any success.

MySQL Version: 4.1.21

Configure:
'./configure' '--enable-pic' '--with-libdir=lib64' '--prefix=/usr/local' '--with-xml' '--enable-bcmath' '--enable-calendar' '--with-curl' '--with-dom' '--with-dom-xslt' '--with-dom-exslt' '--enable-exif' '--enable-ftp' '--with-gd' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6' '--with-gettext' '--with-iconv' '--with-imap=/usr/local/imap-2004g' '--enable-mbstring' '--enable-mbstr-enc-trans' '--enable-mbregex' '--with-mcrypt' '--with-mhash' '--enable-magic-quotes' '--with-mysql=/usr' '--with-mysqli=/usr/bin/mysql_config' '--with-snmp' '--enable-ucd-snmp-hack' '--with-openssl' '--with-pear' '--with-pspell' '--enable-sockets' '--enable-track-vars' '--with-ttf' '--with-freetype-dir=/usr' '--enable-gd-native-ttf' '--enable-wddx' '--with-xmlrpc' '--with-zip' '--with-zlib' '--prefix=/usr/local/php5' '--exec-prefix=/usr/local/php5' '--program-suffix=5' '--enable-force-cgi-redirect' '--disable-discard-path' '--with-pdo-mysql'

Reproduce code:
---------------
<?php
$foo = function_exists('mysqli_connect');
if ($foo) {
  echo "Mysqli available";
} else {
  echo "Mysqli not available";
}

Expected result:
----------------
Mysqli available

Actual result:
--------------
Mysqli not available

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-07-05 13:54 UTC] tony2001@php.net
Cannot reproduce.
Try to remove all the configure options and leave only --with-mysqli and then add options one by one to see which one causes the problem.
 [2007-07-09 21:33 UTC] ben at popator dot com
Bogus bug. User error.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Apr 12 22:01:29 2024 UTC