|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41761 /usr/lib64 not found
Submitted: 2007-06-21 12:41 UTC Modified: 2007-06-21 13:51 UTC
From: no at no dot no Assigned: pajoye (profile)
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.2.3 OS: RHEL 5 x86_64
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: no at no dot no
New email:
PHP Version: OS:


 [2007-06-21 12:41 UTC] no at no dot no
Bug #33685 still happens. Same error with not finding stuff from /usr/lib64 , same workaround in RHEL 5/64 with php 5.2.3 configure.

configure: error: libjpeg.(a|so) not found.

symbolic linking mention in Bug #33685 to opt fixes it (and png, and mysql)


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2007-06-21 12:56 UTC]
"Yes I tried it with '--libdir=/usr/lib64', with and without
--with-jpeg-dir and got same error."

That's wrong. You have to tell which suffix it has to use, not the full path. --with-libdir=lib64 or --with-libdir=/lib64 (not sure if / is required)
 [2007-06-21 13:22 UTC]
The correct option to use is '--with-libdir=lib64'. No bug here.
 [2007-06-21 13:25 UTC]
You still have to use --with-png-dir=/usr and --with-jpeg-dir=/usr /usr is the prefix. Did you use these options?

Reading your configure line:
'--libdir=/usr/lib64' is _wrong_.

It is --libdir=lib64 and works pretty well so far.
 [2007-06-21 13:26 UTC]
still bogus 
 [2007-06-21 13:45 UTC] no at no dot no
'--libdir=/lib64' or '--libdir=/lib64/'
configure: error: libpng.(a|so) not found.

configure: error: expected an absolute directory name for --libdir: lib64

What works is

ln -s /usr/include /opt/include
ln -s /usr/lib64 /opt/lib
./configure '--prefix=/php5' '--with-config-file-path=/opt/lsws/php5' '--with-litespeed'  '--libdir=/usr/lib64' '--with-jpeg-dir=/opt' '--with-ttf' '--with-png' '--with-png-dir=/opt''--with-gd' '--enable-gd-native-ttf' '--enable-exif' '--enable-ftp' '--with-mysql=/opt' '--with-mysql-sock=/tmp/mysql.sock' '--enable-memory-limit' '--with-zlib' '--with-openssl' '--with-curl'  '--enable-magic-quotes' '--enable-mbstring' '--enable-mbstr-enc-trans' '--enable-mbregex' '--enable-bcmath' '--enable-calendar' '--enable-sockets' '--enable-zip' '--enable-shmop' '--enable-track-vars' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--with-pear=/usr/lib64/php/pear' '--disable-cgi' '--disable-debug'

 [2007-06-21 13:51 UTC] no at no dot no
Thanks Sniper. This works:

./configure '--prefix=/php5' '--with-config-file-path=/opt/lsws/php5' '--with-litespeed'  '--with-libdir=lib64' '--with-ttf' '--with-png' '--with-gd' '--enable-gd-native-ttf' '--enable-exif' '--enable-ftp' '--with-mysql' '--with-mysql-sock=/tmp/mysql.sock' '--enable-memory-limit' '--with-zlib' '--with-openssl' '--with-curl'  '--enable-magic-quotes' '--enable-mbstring' '--enable-mbstr-enc-trans' '--enable-mbregex' '--enable-bcmath' '--enable-calendar' '--enable-sockets' '--enable-zip' '--enable-shmop' '--enable-track-vars' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--with-pear=/usr/lib64/php/pear' '--disable-cgi' '--disable-debug'

I still think configure should be more tolerant.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Jul 21 17:01:30 2024 UTC