php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41708 error on comparission
Submitted: 2007-06-15 19:50 UTC Modified: 2007-06-15 23:48 UTC
From: killton at gmail dot com Assigned:
Status: Not a bug Package: Strings related
PHP Version: 5.2.3 OS: LINUX
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: killton at gmail dot com
New email:
PHP Version: OS:

 

 [2007-06-15 19:50 UTC] killton at gmail dot com
Description:
------------
When i do a comparission between a number and an empty string

Reproduce code:
---------------
$var = ''

if (0 == $var)
    echo "This is bad";
else
    echo "do some";


Expected result:
----------------
An empty string should not be equals to 0


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-06-15 23:48 UTC] scottmac@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


The second operand is converted to the first operand type, in this case the string '' is converted to an integer, as there are no numeric parts of '', as it needs to be some sort of value it is assigned 0.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Apr 21 12:01:29 2024 UTC