php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41687 Array named from other variable doesn't return value for given index
Submitted: 2007-06-14 11:26 UTC Modified: 2007-06-14 11:45 UTC
From: dr dot diesel at seznam dot cz Assigned:
Status: Not a bug Package: Arrays related
PHP Version: 5.2.3 OS: Win XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dr dot diesel at seznam dot cz
New email:
PHP Version: OS:

 

 [2007-06-14 11:26 UTC] dr dot diesel at seznam dot cz
Description:
------------
Code snippet says everything:

$arrname="my_array";
$$arrname = array("test","test2");

var_export($$arrname) outputs: array ( 0 => '204', 1 => '205', )
var_export($$arrname[0]) outputs: NULL

$test=$$arrname;

var_export($test) outputs: array ( 0 => '204', 1 => '205', )
var_export($test[0]) outputs:'204'

Reproduce code:
---------------
$arrname="my_array";
$$arrname = array("test","test2");

var_export($$arrname); 
var_export($$arrname[0]); 

$test=$$arrname;

var_export($test);
var_export($test[0]);

Expected result:
----------------
$arrname="my_array";
$$arrname = array("test","test2");

var_export($$arrname) outputs: array ( 0 => '204', 1 => '205', )
var_export($$arrname[0]) outputs: >>>>>>>>'204'<<<<<<<<<

$test=$$arrname;

var_export($test) outputs: array ( 0 => '204', 1 => '205', )
var_export($test[0]) outputs:'204'

Actual result:
--------------
$arrname="my_array";
$$arrname = array("test","test2");

var_export($$arrname) outputs: array ( 0 => '204', 1 => '205', )
var_export($$arrname[0]) outputs: NULL

$test=$$arrname;

var_export($test) outputs: array ( 0 => '204', 1 => '205', )
var_export($test[0]) outputs:'204'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-06-14 11:29 UTC] dr dot diesel at seznam dot cz
Sorry, $$arrname  = array(204,205); should be the second line.
 [2007-06-14 11:45 UTC] scottmac@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

$$arrname[0] becomes $m since $arname[0] is the first character of $arname.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Oct 28 06:03:33 2021 UTC