php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41636 Warning: dl() [function.dl]: Unable to load dynamic library '%PATH%'
Submitted: 2007-06-08 16:22 UTC Modified: 2007-06-13 05:43 UTC
From: jason dot zhou at bertelsmann dot com dot cn Assigned:
Status: Not a bug Package: *Extensibility Functions
PHP Version: 5.2.3 OS: SuSE Linux 9
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jason dot zhou at bertelsmann dot com dot cn
New email:
PHP Version: OS:

 

 [2007-06-08 16:22 UTC] jason dot zhou at bertelsmann dot com dot cn
Description:
------------
I have installed 'pecl_http',and modified php.ini, the extension_dir="/usr/local/php/lib/php/extensions/no-debug-non-zts-20060613/"  and extension=http.so. But i still get errors like below:

Warning: dl() [function.dl]: Unable to load dynamic library '/usr/local/php/lib/php/extensions/no-debug-non-zts-20060613/http.so' - /usr/local/php/lib/php/extensions/no-debug-non-zts-20060613/http.so: undefined symbol: OnUpdateLong in /data/int/index.php on line 9

Fatal error: Call to undefined function http_get() in /data/cms/mx/frontend/cfrontcache.php on line 456


I have tried to change the extension_dir=/usr/local/php/modules/  but from the phpinfo.php  it still the "/usr/.../no-debug...20060613"

Reproduce code:
---------------
Warning: dl() [function.dl]: Unable to load dynamic library '/usr/local/php/lib/php/extensions/no-debug-non-zts-20060613/http.so' - /usr/local/php/lib/php/extensions/no-debug-non-zts-20060613/http.so: undefined symbol: OnUpdateLong in /data/int/index.php on line 9

Fatal error: Call to undefined function http_get() in /data/cms/mx/frontend/cfrontcache.php on line 456


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-06-09 08:06 UTC] johannes@php.net
The so you're trying to laod was compiled using another PHP version. Please make sure you're using the same PHP while compiling and using the extension.

btw. you shouldn't use dl() but only extension=....so in your php.ini file.

For future issues: Please report issues about PECL extensions at http://pecl.php.net
 [2007-06-13 05:43 UTC] jason dot zhou at bertelsmann dot com dot cn
Hi Johannes,

Thanks a lot for your help!

You are right, I have too different version php installed. And now I have reinstalled the server, and only installed Apache/2.2.4 (Unix) PHP/5.2.3? pecl_http-1.5.3 

I have add the extension_dir=  and extension=http.so  to  the php.ini file.

But it looks like the php didn't try to load the extension, also I use /usr/local/php/bin/php -m command to test the load, I didn't see http in the list. 

Would you please let me know where is the problem? What else should i do?

Thanks!
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jan 24 07:01:24 2020 UTC