php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41565 Windows install package broken
Submitted: 2007-06-01 16:33 UTC Modified: 2008-08-22 18:13 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: phpbug at profitlich dot net Assigned: jmertic (profile)
Status: Not a bug Package: Windows Installer
PHP Version: 5.2.3 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: phpbug at profitlich dot net
New email:
PHP Version: OS:

 

 [2007-06-01 16:33 UTC] phpbug at profitlich dot net
Description:
------------
php-5.2.3-win32-installer.msi 

is not working from commandline after installation

I installed it with all options, started php.exe and it told me that the Extensions couldnt be found in the path at the specific position, but the files where there!




Actual result:
--------------
C:\php.exe >1
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\Programme\PHP\ext\
php_exif.dll' - Das angegebene Modul wurde nicht gefunden.
 in Unknown on line 0
PHP Warning:  Module 'imap' already loaded in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\Programme\PHP\ext\
php_oci8.dll' - Das angegebene Modul wurde nicht gefunden.
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\Programme\PHP\ext\
php_pdo_oci.dll' - Das angegebene Modul wurde nicht gefunden.
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\Programme\PHP\ext\
php_pdo_oci8.dll' - Das angegebene Modul wurde nicht gefunden.
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\Programme\PHP\ext\
php_pdo_sqlite_external.dll' - Das angegebene Modul wurde nicht gefunden.
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\Programme\PHP\ext\
php_pspell.dll' - Das angegebene Modul wurde nicht gefunden.
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\Programme\PHP\ext\
php_sybase_ct.dll' - Das angegebene Modul wurde nicht gefunden.
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\Programme\PHP\ext\
php_ibm_db2.dll' - Das angegebene Modul wurde nicht gefunden.
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\Programme\PHP\ext\
php_ifx.dll' - Das angegebene Modul wurde nicht gefunden.
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\Programme\PHP\ext\
php_ingres.dll' - Das angegebene Modul wurde nicht gefunden.
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\Programme\PHP\ext\
php_maxdb.dll' - Das angegebene Modul wurde nicht gefunden.
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\Programme\PHP\ext\
php_mcve.dll' - Das angegebene Modul wurde nicht gefunden.
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\Programme\PHP\ext\
php_netools.dll' - Das angegebene Modul wurde nicht gefunden.
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\Programme\PHP\ext\
php_oracle.dll' - Das angegebene Modul wurde nicht gefunden.
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\Programme\PHP\ext\
php_pdo_ibm.dll' - Das angegebene Modul wurde nicht gefunden.
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\Programme\PHP\ext\
php_pdo_informix.dll' - Das angegebene Modul wurde nicht gefunden.
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\Programme\PHP\ext\
php_svn.dll' - Das angegebene Modul wurde nicht gefunden.
 in Unknown on line 0
Cannot find module (IP-MIB): At line 0 in (none)
Cannot find module (IF-MIB): At line 0 in (none)
Cannot find module (TCP-MIB): At line 0 in (none)
Cannot find module (UDP-MIB): At line 0 in (none)
Cannot find module (SNMPv2-MIB): At line 0 in (none)
Cannot find module (SNMPv2-SMI): At line 0 in (none)
Cannot find module (UCD-SNMP-MIB): At line 0 in (none)
Cannot find module (UCD-DEMO-MIB): At line 0 in (none)
Cannot find module (SNMP-TARGET-MIB): At line 0 in (none)
Cannot find module (SNMP-VIEW-BASED-ACM-MIB): At line 0 in (none)
Cannot find module (SNMP-COMMUNITY-MIB): At line 0 in (none)
Cannot find module (UCD-DLMOD-MIB): At line 0 in (none)
Cannot find module (SNMP-FRAMEWORK-MIB): At line 0 in (none)
Cannot find module (SNMP-MPD-MIB): At line 0 in (none)
Cannot find module (SNMP-USER-BASED-SM-MIB): At line 0 in (none)
Cannot find module (SNMP-NOTIFICATION-MIB): At line 0 in (none)
Cannot find module (SNMPv2-TM): At line 0 in (none)
PHP Notice:  Constant XML_ELEMENT_NODE already defined in Unknown on line 0
PHP Notice:  Constant XML_ATTRIBUTE_NODE already defined in Unknown on line 0
PHP Notice:  Constant XML_TEXT_NODE already defined in Unknown on line 0
PHP Notice:  Constant XML_CDATA_SECTION_NODE already defined in Unknown on line
0
PHP Notice:  Constant XML_ENTITY_REF_NODE already defined in Unknown on line 0
PHP Notice:  Constant XML_ENTITY_NODE already defined in Unknown on line 0
PHP Notice:  Constant XML_PI_NODE already defined in Unknown on line 0
PHP Notice:  Constant XML_COMMENT_NODE already defined in Unknown on line 0
PHP Notice:  Constant XML_DOCUMENT_NODE already defined in Unknown on line 0
PHP Notice:  Constant XML_DOCUMENT_TYPE_NODE already defined in Unknown on line
0
PHP Notice:  Constant XML_DOCUMENT_FRAG_NODE already defined in Unknown on line
0
PHP Notice:  Constant XML_NOTATION_NODE already defined in Unknown on line 0
PHP Notice:  Constant XML_HTML_DOCUMENT_NODE already defined in Unknown on line
0
PHP Notice:  Constant XML_DTD_NODE already defined in Unknown on line 0
PHP Notice:  Constant XML_ELEMENT_DECL_NODE already defined in Unknown on line 0

PHP Notice:  Constant XML_ATTRIBUTE_DECL_NODE already defined in Unknown on line
 0
PHP Notice:  Constant XML_ENTITY_DECL_NODE already defined in Unknown on line 0
PHP Notice:  Constant XML_NAMESPACE_DECL_NODE already defined in Unknown on line
 0
PHP Notice:  Constant XML_LOCAL_NAMESPACE already defined in Unknown on line 0
PHP Notice:  Constant XML_ATTRIBUTE_CDATA already defined in Unknown on line 0
PHP Notice:  Constant XML_ATTRIBUTE_ID already defined in Unknown on line 0
PHP Notice:  Constant XML_ATTRIBUTE_IDREF already defined in Unknown on line 0
PHP Notice:  Constant XML_ATTRIBUTE_IDREFS already defined in Unknown on line 0
PHP Notice:  Constant XML_ATTRIBUTE_ENTITY already defined in Unknown on line 0
PHP Notice:  Constant XML_ATTRIBUTE_NMTOKEN already defined in Unknown on line 0

PHP Notice:  Constant XML_ATTRIBUTE_NMTOKENS already defined in Unknown on line
0
PHP Notice:  Constant XML_ATTRIBUTE_ENUMERATION already defined in Unknown on li
ne 0
PHP Notice:  Constant XML_ATTRIBUTE_NOTATION already defined in Unknown on line
0
PHP Warning:  require_once(SAM/php_sam.php): failed to open stream: No such file
 or directory in sam_factory on line 1
PHP Fatal error:  require_once(): Failed opening required 'SAM/php_sam.php' (inc
lude_path='.;C:\Programme\PHP\pear') in sam_factory on line 1
Error in my_thread_global_end(): 4 threads didn't exit




#################

the file "1" contains:

Could not startup.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-06-01 16:54 UTC] phpbug at profitlich dot net
It seems that the msi package is broken since ages, so why not removing it? it seems to make the most problems in the Windows world.


for example a former similar bug: #40700
 [2007-06-04 08:41 UTC] tony2001@php.net
John, is the installer supposed to enable all the available extensions?
 [2007-06-04 11:37 UTC] jmertic@php.net
The installer only enables the extensions the user requests. The manual specifically says to only enable the modules you need, and no other ones.

Also, please be aware that many of the additional modules ( such as the oracle, db2, sqllite_external related ones ) require additional dlls to be installed that do not ship with PHP for various reasons. You will need to install any external requirements separately.

We have many, many people ( including myself ) using the msi installer successfully in production situations.

I would try going thru 'Add/Remove Programs' then go to 'PHP 5.2.2' and 'Change', and then 'Change' again. When you are back at the tree menu only install the items under 'Extensions' that you actually are using.
 [2007-06-05 10:04 UTC] tony2001@php.net
.
 [2007-06-05 12:07 UTC] phpbug at profitlich dot net
In the Windows world, the full installation of msi packages should work. If you are surfing around, you?ll read more than a few comments about this problem. 
A msi packages, with all installed options should work, otherwise its broken. 
At this point it starts to be a religious theme, so lets stop. If you don?t care about this problem, please insert a warning like "If you install all options, without having the dll?s, the installation will be broken."

closed?
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Dec 03 07:03:34 2021 UTC