php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #41500 JSON encode limit should be variable
Submitted: 2007-05-25 15:26 UTC Modified: 2010-09-16 15:49 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: tobi at struckmeier dot name Assigned:
Status: Not a bug Package: JSON related
PHP Version: 5.2.3RC1 OS: irrelevant
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tobi at struckmeier dot name
New email:
PHP Version: OS:

 

 [2007-05-25 15:26 UTC] tobi at struckmeier dot name
Description:
------------
Current nesting level is hardcoded to 128.
Should be a parameter like

string json_encode ( mixed $value [,int $limit] )

where $limit is an optional parameter that defaults to 128.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-09-16 15:48 UTC] aharvey@php.net
-Package: Feature/Change Request +Package: JSON related
 [2010-09-16 15:48 UTC] aharvey@php.net
There's no longer a limit on encoding in 5.3 and trunk; the only limitation is caused by the OS stack size.
 [2010-09-16 15:49 UTC] aharvey@php.net
-Status: Open +Status: Bogus
 [2010-09-16 15:49 UTC] aharvey@php.net
I did also mean to close this. Sorry about the noise.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Nov 14 18:01:35 2019 UTC