php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4146 will not compile with Solid EE 3.5 (3.0, too)
Submitted: 2000-04-14 10:12 UTC Modified: 2000-07-24 16:21 UTC
From: gordon+php at vip dot fi Assigned: kalowsky (profile)
Status: Closed Package: Solid related
PHP Version: 4.0 Release Candidate 1 OS: Linux 2.2.14-5.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gordon+php at vip dot fi
New email:
PHP Version: OS:

 

 [2000-04-14 10:12 UTC] gordon+php at vip dot fi
There hasn't been any progress with Solid support since 3.0.x; there are still numerous problems with Solid and PHP 3.0.x (apache will not start unless mod_php is the first module on the loadable module list, will not restart gracefully - has to be stopped and started explicitly), and now with Solid 3.5 the library and include file names have changed (again) and PHP won't compile without kicking the source around (and I still haven't been able to compile though I kind of know what I'm doing :).

Though I've gone through the motions to make configure and the appropriate headers reflect the new library and include file names, there are a lot of errors when compiling (and the compile fails). There are a lot of 
"php_odbc.c:154: warning: passing arg 1 of `SQLTransact' makes integer from pointer without a cast" errors. This is probably due to the changed includes, but I'm not capable enough to trace the problem to its source.

Is anyone doing anything with Solid & PHP anymore? The "bugs" I've reported have not been acted upon... Has anyone gotten PHP 3.0.x/4 to work _without problems_ with Solid 3.x?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-01 20:48 UTC] kalowsky at cvs dot php dot net
updates created working on merging with 4.0.1 
and a small user test group.  also fixing(?) the DSO problem many
had with the solid db/php/apache mixture.

hope to fix SolidEE 3.0 as well, but no test systems available

have not been able to remove the warning of 
"integer from pointer without a cast" but that hasn't seemed
to hurt the build at all.
 [2000-07-14 12:15 UTC] kalowsky at cvs dot php dot net
I believe 3.5 works.  3.0?  No idea, I don't have a copy of it or any place where to test.  2.3 and PHP4 still doest no seem to work.  Suggested course of action is upgrading to 3.5 (easy answer yes, but again no ability to test, and drastic differences between the 3.5 and 2.3).

3.5 has been found also to work with Apache as a DSO.  
 [2000-07-24 16:21 UTC] kalowsky@php.net
closed at this time.  test and send reports back to php-dev
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Jan 23 22:01:25 2020 UTC