php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41457 Quoted fields come back corrupted, using GROUP BY
Submitted: 2007-05-21 13:17 UTC Modified: 2007-05-21 14:01 UTC
From: troelskn at gmail dot com Assigned:
Status: Not a bug Package: SQLite related
PHP Version: 5.2.2 OS: windows xp
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
10 + 24 = ?
Subscribe to this entry?

 
 [2007-05-21 13:17 UTC] troelskn at gmail dot com
Description:
------------
When executing a query, where field names are quoted, and using GROUP BY, the field names are returned with quotes around.

This error may very well be in sqlite, and not with PHP, but I have no way of verifying that hunch.

Using SQLite:

SQLite support => enabled
PECL Module version => 2.0-dev $Id: sqlite.c,v 1.166.2.13.2.7 2007/03/06 02:17:13 stas Exp $
SQLite Library => 2.8.17
SQLite Encoding => iso8859


Reproduce code:
---------------
<?php
$db = sqlite_open(":memory:");
sqlite_query($db, '
  CREATE TABLE test (
    id INTEGER PRIMARY KEY
  )
');
sqlite_query($db, "INSERT INTO test (id) VALUES (1)");
$result = sqlite_query($db, 'SELECT "id" FROM "test" GROUP BY "id"');
var_dump(sqlite_fetch_array($result, SQLITE_ASSOC));

Expected result:
----------------
array(1) {
  ["id"]=>
  string(1) "1"
}


Actual result:
--------------
array(1) {
  [""id""]=>
  string(1) "1"
}


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-05-21 14:01 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

PHP simply returns back the text that was provided by sqlite library. In 
this case the column name as returned includes quotes, so they are 
returned.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Mon Jan 30 20:03:45 2023 UTC