php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4144 mktime() returns false value since 27th March 2000
Submitted: 2000-04-14 04:21 UTC Modified: 2000-04-14 04:50 UTC
From: Istvan dot Czeh at uti dot hu Assigned:
Status: Closed Package: Other
PHP Version: 3.0.16 OS: Debian Linux 2.1,2.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Istvan dot Czeh at uti dot hu
New email:
PHP Version: OS:

 

 [2000-04-14 04:21 UTC] Istvan dot Czeh at uti dot hu
I think I discovered a bug. If it's so, than it's a really strange bug. Until 26th March 2000, mktime() returns the right value, but since 27th of March it returns a false value.

the following simple script should return 86400 (one day in seconds), but it returns 82800. (one hour less):
	echo (mktime(0,0,0,3,27,2000) - mktime(0,0,03,26,2000));

before 27th March 2000 there is no problem:
	echo (mktime(0,0,0,3,26,2000) - mktime(0,0,03,25,2000))
returns 86400.

The bug was discovered in the version 3.0.12. Today I downloded 3.0.16, but it still has the problem.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-04-14 04:50 UTC] jah at cvs dot php dot net
It's not a bug (or, at least not a bug in PHP). Most European countries
switched to summertime  at 03.00, 26th of March, and moved the clocks one
hour forward. So there really is only 23 hours between 2000-03-26 00:00:00
and 2000-03-27 00:00:00 in certain countries. If Hungary didn't switch to
summertime, then the bug is either incorrect timezone setting on your part, or
a bug in Debians timezone files.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed May 22 17:01:32 2024 UTC