php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41437 Installation fails due to script error
Submitted: 2007-05-18 15:59 UTC Modified: 2008-08-22 18:13 UTC
From: dane_carty at hotmail dot com Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.2.2 OS: Server2003
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: dane_carty at hotmail dot com
New email:
PHP Version: OS:

 

 [2007-05-18 15:59 UTC] dane_carty at hotmail dot com
Description:
------------
FAULT

When installing 5.2.2 on Windows Server 2003 Standard, the installation succedes, but IIS doesn't find PHP, so each time you load a PHP page , it gives 404 error - page not found.

FIX

In fact if you look at the properties of your web site, check the home directory tab, click on configuration (for the applications settings) amd scroll down to PHP, you'll see that the PHP installer has added an extra \  eg C:\PHP\\php5isapi.dll  Correct this and all is ok. 

It took me a day of reloading all sorts of versions of 2003, IIS and PHP 5.2.2 before I found this !!


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-05-18 16:12 UTC] jmertic@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.

Duplicate of Bug #41367. This will be fixed in a respin of the installer in the next few days.
 [2007-05-21 18:29 UTC] jmertic@php.net
Try the following "unoffical" re-spin:

http://files.edin.dk/php/installer/php-5.2.2-2-win32-installer.msi

 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Dec 06 09:01:28 2023 UTC