php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41379 Comment colors on sample code
Submitted: 2007-05-12 19:39 UTC Modified: 2010-11-06 22:02 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: michaeldaly at magma dot ca Assigned: frozenfire (profile)
Status: Closed Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: michaeldaly at magma dot ca
New email:
PHP Version: OS:

 

 [2007-05-12 19:39 UTC] michaeldaly at magma dot ca
Description:
------------
The current code samples in the PHP manual online use orange text on a grey background for comments.

As a person with some red-green colorblindness, I find this exceptionally hard to read - to the point I can't read some comments at all.  The red text is slightly better, but the orange is awful.

Would it be possible to change the comment color to something else with more contrast?  It may be worthwhile considering a different background color to enhance the contrast.

I use EditPlus as an editor and its default colors for PHP source are much easier to read with a white background.  Comments are green, and various keywords are red, teal, blue, and brown with violet quoted strings.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-11-06 22:02 UTC] frozenfire@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: frozenfire
 [2010-11-06 22:02 UTC] frozenfire@php.net
I believe that the example colour scheme has been changed since this bug was filed. I'm closing it due to the issue no longer existing.

If I'm wrong in doing so, please feel free to add a comment.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Tue Feb 07 04:05:50 2023 UTC