php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41332 PHPInfo not showing full ./configure used
Submitted: 2007-05-08 20:17 UTC Modified: 2007-05-08 20:54 UTC
From: chawming at pacific dot net dot sg Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.2.2 OS: RHEL 3 Taroon 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: chawming at pacific dot net dot sg
New email:
PHP Version: OS:

 

 [2007-05-08 20:17 UTC] chawming at pacific dot net dot sg
Description:
------------
The ./configure parameter displayed in phpinfo, either in a PHP script with phpinfo() or in CLI display a truncated version of the actual configuration used

Reproduce code:
---------------
php -i | grep ./configure | sed s#"'"#""#g

Expected result:
----------------
./configure  --program-prefix= --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc
 --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com --mandir=/usr/share/man --cache-file=../config.cache --enable-force-cgi-redirect --disable-debug -disable-rpath --enable-inline-optimization --with-bz2 --with-d4=/usr --with-curl --with-dom=/usr --with-exec-dir=/usr/bin --with-png-dir=/usr --with-gd --enable-gd-native-ttf --with-ttf --with-gettext --with-ncurses --with-gmp --with-iconv -with-jpeg-dir=/usr --with-openssl --with-png --with-pspell --with-regex=system --with-xml --with-expat-dir=/usr --with-zlib --with-layout=GNU --enable-bcmath --enable-exif --enable-ftp --enable-magic-quotes --enable-safe-mode --enable-sockets --enable-sysvsem --enable-sysvshm --enable-discard-path --enable-track-vars --enable-trans-sid --enable-yp --enable-wddx --enable-mbstring --enable-mbstr-enc-trans --enable-mbregex --with-pear=/usr/share/pear --with-kerberos=/usr/kerberos --with-ldap=shared --with-mysql=/usr/bin/mysql_config --enable-memory-limit --enable-bcmath --enable-calendar --enable-dbx --enable-dio --enable-mcal --with-apxs2filter=/usr/sbin/apxs

Actual result:
--------------
./configure --program-prefix= --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib --libexecdir=/usr/libexec --localstatedir=/var --sharedstat

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-05-08 20:20 UTC] tony2001@php.net
-with-jpeg-dir=/usr -disable-rpath
Fix your configure line and try again.
 [2007-05-08 20:47 UTC] chawming at pacific dot net dot sg
That worked. Thanks.

But shouldn't configure fail if there are invalid parameters? In this case, whatever is not showing in phpinfo is actually still compiled in e.g. mysql ext etc.
 [2007-05-08 20:54 UTC] tony2001@php.net
>But shouldn't configure fail if there are invalid parameters? 
No, it should not.

>In this case, whatever is not showing in phpinfo is actually still 
>compiled in e.g. mysql ext etc.
If you have an idea of how to parse the line correctly and still be able to generate correct ./config.nice - please come up with a patch, that would be very much appreciated.

But I personally would prefer to avoid touching this very sensitive part 'cause I've already spent too much time making this code to work with newer versions of autoconf.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 11 18:03:36 2022 UTC