php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4130 sed errors while building Oracle support
Submitted: 2000-04-13 08:56 UTC Modified: 2000-08-20 01:55 UTC
From: ed-hill at uiowa dot edu Assigned:
Status: Closed Package: Installation problem
PHP Version: 4.0 Release Candidate 1 OS: AIX 4.3.2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: ed-hill at uiowa dot edu
New email:
PHP Version: OS:

 

 [2000-04-13 08:56 UTC] ed-hill at uiowa dot edu
I'm running AIX 4.3.2, and configuring php in the following way

./configure --with-mysql=/local/mysql
            --with-apache=../apache_1.3.12
            --enable-track-vars
            --prefix=/local/www.php/php
            --with-oracle=/ora00/app/oracle/product/7.3.4

Towards the end of the configuration process, I get a number of "sed" errors, listed below.  I also get these errors if I let configure default to the $ORACLE_HOME path.

I don't get these errors if I leave off the --with-oracle option.

I've grabed the latest GNU sed, and tried using it thinking it might be an AIX oddity, but that just results in a different error message.

AIX-sed:
 creating php4.spec
 sed: Function s%@EXTRA_LIBS@%   -L/ora00/app/oracle/product/7.3.4/lib
 -R/ora00/app/oracle/product/7.3.4/lib -lclient -lsqlnet -lncr -lsqlnet
 -lclient -lcommon              -lgeneric -lsqlnet -lncr -lsqlnet -lclient
 -lcommon -lgeneric             -lepc -lnlsrtl3 -lc3v6 -lcore3 -lnlsrtl3
 -lcore3 -lnlsrtl3             -lm -lld -lm  cannot be parsed.
 creating Zend/Makefile
 sed: Function s%@EXTRA_LIBS@%   -L/ora00/app/oracle/product/7.3.4/lib
 -R/ora00/app/oracle/product/7.3.4/lib -lclient -lsqlnet -lncr -lsqlnet
 -lclient -lcommon              -lgeneric -lsqlnet -lncr -lsqlnet -lclient
 -lcommon -lgeneric             -lepc -lnlsrtl3 -lc3v6 -lcore3 -lnlsrtl3
 -lcore3 -lnlsrtl3             -lm -lld -lm  cannot be parsed.

GNU-sed:
 creating php4.spec
 sed: file conftest.s2 line 25: Unterminated `s' command
 creating Zend/Makefile
 sed: file conftest.s2 line 25: Unterminated `s' command


Because of these errors, the various Makefiles do not get generated, and you can't go any further.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-08-01 23:32 UTC] waldschrott@php.net
Please verify that it?s still happening using the latest version of PHP (release 4.0.1pl2 or CVS).
 [2000-08-20 01:55 UTC] sniper@php.net
No feedback from user.

--Jani
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue May 24 10:05:44 2022 UTC