php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41234 additional info
Submitted: 2007-04-30 04:56 UTC Modified: 2007-04-30 13:29 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: cpriest at warpmail dot net Assigned:
Status: Not a bug Package: MySQLi related
PHP Version: 5.2.1 OS: Windows Vista Business
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: cpriest at warpmail dot net
New email:
PHP Version: OS:

 

 [2007-04-30 04:56 UTC] cpriest at warpmail dot net
Description:
------------
Unable to get php_mysqli.dll to load properly on Windows Vista Business with Apache 2.0.59 or 2.2.x.

Reproduce code:
---------------
Install Apache 2.0.59 + PHP 5.2.1
Try loading the php_mysqli.dll

Expected result:
----------------
Able to load extension

Actual result:
--------------
Cannot load, get error "Procedure could not be found."

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-04-30 05:02 UTC] cpriest at warpmail dot net
I have verified the following:
 - libmysql.dll is located in c:\php
 - c:\php is in the environment PATH variable (rebooted afterwards)
 - php_mysql.dll and php_mysqli.dll are both in .\ext and are being loaded (mysqli load fails)

I have also tried the following:
 - Apache 2.2.x
 - Copying the libmysql.dll to c:\windows\system32
 - Copying the libmysql.dll from my MySQL 4.1.x installation into c:\php 

All result in the same error "Procedure could not be found" while loading php_mysqli.dll

I'm reasonably certain that this is related to my Windows Vista Business install, I have successfully installed this environment many times before on Windows XP and Linux installations with no problems.
 [2007-04-30 11:32 UTC] edink@php.net
You probably have another libmysql.dll or you have mixed up several PHP installs. The mysqli extension works fine.
 [2007-04-30 13:29 UTC] cpriest at warpmail dot net
I've done a fresh install of both Apache and PHP twice.  Default installation.  I guess I'll try it again.  No other reports of issues on Vista have shown up?
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jul 06 17:05:44 2022 UTC