|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41229 PHP as fastcgi module crashes
Submitted: 2007-04-29 18:55 UTC Modified: 2007-05-08 01:00 UTC
Avg. Score:4.6 ± 0.8
Reproduced:4 of 4 (100.0%)
Same Version:2 (50.0%)
Same OS:0 (0.0%)
From: admin at torrent dot lt Assigned:
Status: No Feedback Package: CGI/CLI related
PHP Version: 5.2.1 OS: gentoo
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: admin at torrent dot lt
New email:
PHP Version: OS:


 [2007-04-29 18:55 UTC] admin at torrent dot lt
moving from debian PHP 5.2.0-8 (cgi-fcgi) (built: Dec 17 2006 19:57:41)
to gentoo PHP 5.1.6-pl11-gentoo (cgi-fcgi) (built: Apr 29 2007 12:43:38) as well as 5.2.1 produces me php segfaultion. Web server (lighttpd) produces me an 500 error code, within only restart of it, helps to solve a problem. Was concerning the bug of xcache (accelerator) as well as trying to downgrade to earlier versions. After monitoring the system for 2-3 days no answers were solved while php keept crashing with or without additional extensions, and with one or other version (tried PHP 4 too). Lastly, I am willing to get a help from you. Will be waiting for your answer.

Reproduce code:

2007-04-25 15:03:01: (mod_fastcgi.c.1711) connect failed: No such file 
or directory on 

Expected result:
examination of the bug

Actual result:
That's only what I could get.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2007-04-29 19:21 UTC]
You need to come up with a gdb backtrace. Sometimes getting one is tricky in this kind of configuration but if you can get a core file generated...try starting lighttpd after setting "ulimit -c unlimited" and you should get the core file.
 [2007-04-29 20:02 UTC] admin at torrent dot lt
I have done the ulimit last week, but under uid0/gid0 I have set ulimit -c unlimited under lighttpd user: su lighttpd ; ulimit -c unlimited, what's more where I could expect the core file to be dumped? and how to make it done?

I have just got the 500 error (after setting the ulimit) I reckon' that before stating the 500 internal error the webserver is starting to act extremely slow, the webpages hardly open's and so on. I have 1000 queries to mysql per sec.

Will be waiting for your answers.
I've got these errors.
 [2007-04-29 21:09 UTC]
Start lighttpd without it forking. And only have 1 child for PHP started. You don't need to "su lighttpd", just do the ulimit thing as root. 
 [2007-04-29 23:21 UTC] admin at torrent dot lt
The ulimit thing was already done last Thursday, I have set these variables as told. Nothing happened, the website is working fine, but the traffic and the number of users are less than more ten times than in a day.
"bin-path" => "/usr/bin/php-cgi", "max-procs" => 25, idle-timeout" => 9,
"bin-environment" => ("PHP_FCGI_CHILDREN" => "1",                        "PHP_FCGI_MAX_REQUESTS" => "100000"
 [2007-04-30 13:06 UTC]
And no core files anywhere? find / -name 'core*' :)
 [2007-05-08 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2007-05-25 14:45 UTC] host4cheap at yahoo dot com
Any Updates on this. I face the same problem on CentOS with Lighttpd.

I get these ERROR after some time
2007-05-22 21:03:41: (log.c.75) server started 
2007-05-22 21:33:53: (server.c.1149) NOTE: a request for /forum/index.php?act=rssout&id=5 timed out after writing 13068 bytes. We waited 360 seconds. If this a problem increase server.max-write-idle 
2007-05-22 21:36:35: (server.c.1149) NOTE: a request for /forum/index.php?showtopic=51680 timed out after writing 13032 bytes. We waited 360 seconds. If this a problem increase server.max-write-idle 

Until i restart Webserver, the problem is not fixed only to arise after few hrs. 

PHP Version 5.2.1
 [2008-09-08 20:24 UTC] evert at rooftopsolutions dot nl
Possibly related to #43610?
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue May 21 01:01:31 2024 UTC