php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41100 fopen() not working for w, w+, r+, a
Submitted: 2007-04-16 11:11 UTC Modified: 2007-04-16 11:19 UTC
From: rakeshgouru at gmail dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5CVS-2007-04-16 (snap) OS: Windows xp
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rakeshgouru at gmail dot com
New email:
PHP Version: OS:

 

 [2007-04-16 11:11 UTC] rakeshgouru at gmail dot com
Description:
------------
 newly installed php 5.0.4 on windows xp. php is installed perfectly i checked phpinfo(). Even i worked phpmyadmin for creating database. But whereas fopen() does not work for me in "w" "w+" "x" mode.  Iam getting a message like this Warning: fopen(one.xml) [function.fopen]: failed to open stream: Permission denied in c:\Inetpub\wwwroot\test\phptest2.php on line 3
failure
It was working proper for read.(r)mode, but not working for r+, a, a+,x and x+.
 I think somewhere i should give read and write permissions but i could not find out where. Some one help me.
Thanking them in advance.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-04-16 11:19 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Aug 16 10:05:45 2022 UTC