php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41092 Compile fails on 64bit Fedora due to hardcoded configure paths.
Submitted: 2007-04-15 03:43 UTC Modified: 2007-04-15 10:12 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: mogmios at gmail dot com Assigned:
Status: Wont fix Package: Compile Failure
PHP Version: 4.4.6 OS: Fedora Linux Core 6 x86_64
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mogmios at gmail dot com
New email:
PHP Version: OS:

 

 [2007-04-15 03:43 UTC] mogmios at gmail dot com
Description:
------------
Similar to bug 34722 and 32300. Issue is that Fedora puts 64bit libs in /usr/lib64 instead of /usr/lib. PHP's configure script hard codes paths to use $i/lib/. Simply changing these to $i/lib64 fixes the problem but solution to the problem may not be obvious.

Expected result:
----------------
PHP to compile and run.

Actual result:
--------------
PHP won't compile or run because it can't find libraries during configuration.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-04-15 10:12 UTC] derick@php.net
We won't fix this in 4.4.x as discussed on the lists.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Apr 08 06:01:25 2020 UTC