php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41079 undefined symbol: ap_hook_pre_config
Submitted: 2007-04-13 20:28 UTC Modified: 2007-04-13 20:47 UTC
From: david at ols dot es Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.4.6 OS: Debian
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: david at ols dot es
New email:
PHP Version: OS:

 

 [2007-04-13 20:28 UTC] david at ols dot es
Description:
------------
Cannot load php4 module in Apache 2.2.4

Reproduce code:
---------------
 ./configure --prefix=/usr/local/apache2 \
        --disable-include --disable-actions --disable-asis \
        --disable-cgi --enable-deflate --enable-expires \
        --enable-headers --enable-info --enable-rewrite \
        --enable-so --enable-ssl --enable-usertrack \
        --with-mpm=prefork --with-included-apr

./configure --with-mysql \
        --with-apxs2=/usr/local/apache/bin/apxs \
        --enable-track-vars --enable-versioning \
        --enable-sockets --enable-dbase \
        --enable-exif --with-mm --with-iconv \
        --with-png-dir --enable-ftp \
        --with-xml --with-dbase --with-ftp --with-gdbm \
        --with-imap-ssl=$(IMAP) -with-gd \
        --with-zlib=/usr --with-mime-magic \
        --with-curl=/usr/local --with-openssl \
        --with-pcre --with-mcrypt --disable-cgi \
        --enable-gd-native-ttf --enable-mbstring \
        --enable-inline-optimization \
        --disable-debug --disable-display-source \
        --enable-memory-limit --with-jpeg-dir --with-tiff-dir \
        --without-pear --with-dom

this is very similar to those 'bugs':

http://bugs.php.net/bug.php?id=24199

i know this is has not been cosidered as a real bug, but i did not found anything helpful in any php or apache support site (even using google)

Expected result:
----------------
apache succesfully loads php module

Actual result:
--------------
httpd: Syntax error on line 9 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/modules/libphp4.so into server: /usr/local/apache/modules/libphp4.so: undefined symbol: ap_hook_pre_config


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-04-13 20:47 UTC] tony2001@php.net
This symbol is used and exported in Apache itself. 
nm /usr/local/apache2.2.4/bin/httpd | grep ap_hook_pre_config
Not PHP problem.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Feb 29 17:01:31 2024 UTC