php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4094 complete httpd startup failure with oci8 and virtual hosts
Submitted: 2000-04-10 13:52 UTC Modified: 2006-07-17 09:00 UTC
From: cullin at cometsystems dot com Assigned:
Status: Not a bug Package: OCI8 related
PHP Version: 3.0.16 OS: RedHat Linux 6.0/6.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: cullin at cometsystems dot com
New email:
PHP Version: OS:

 

 [2000-04-10 13:52 UTC] cullin at cometsystems dot com
1) Complie php-4.0b3 or php-4.0RC1 and include support for OCI8.
2) Add a VirtualHost to apache (tested with 1.3.9 and 1.3.12)
3) Restart Apache.

** It appears that it starts just fine, however there will be no httpd processes in a process list

** No information is logged in the access_log, error_log or system log!

If you either remove the VirtualHost devinition *or* recomplie without OCI8 support, the problem will go away.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-01 14:59 UTC] hholzgra@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.

we have oci8 with virtual hosts running fine here since about 4.0.2 ...
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Jan 28 21:01:25 2020 UTC